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Introduction 

Foreword 
The efficiency of a machine tool from the point of view of 
dimensional accuracy or surface definition etc. depends to a 
large degree on the dynamic and static accuracy of the machine 
tool. 
In precision machining it is therefore vital to be able to measure 
and, if necessary, compensate static and dynamic error. 
Guidelines and standards for inspecting machine tools (ISO 
230-2, ISO 230-3, ISO 230-4, German VDI/DGQ guideline 3441 
and ISO 10791-6 K2 and K3) describe a number of measuring 
methods for determining dynamic and static error. 
 
Machine tool builders use the results of machine 
measurements to develop constructive measures for improving 
accuracy. Such measurements also help them to optimize the 
commissioning parameters of the control loop wherever they 
influence the accuracy of a CNC machine. 
 
Machine tool users need the results of machine 
measurements for acceptance testing and regular accuracy 
inspection of their machines. 
 

Dynamic measurements 
Dynamic measurements, particularly for high traversing speeds, 
provide information on contouring behavior that permits 
conclusions both on the condition of the machine tool and on 
the parameter settings of the control loops (consisting of CNC 
control, drives and position feedback systems). 
 
• Circular interpolation test with the KGM and DBB 110 
In the circular interpolation test, the CNC control performs a 
circular interpolation in the working plane. 
 
The KGM Grid Encoder measures the actual path of traverse. 
From this information, the ACCOM evaluation software 
determines deviations from an ideal circular path and displays 
them as a motion error trace on the screen. It also calculates 
the numerical values such as circular error, hysteresis and 
radial error according to ISO 230-4. 
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The DBB 110 Double Ball Bar with integrated linear encoder 
directly measures the radius changes in a circular machine 
movement. 
The results of circular interpolation tests with large radii  
(e.g. with the DBB 110) provide information on the machine 
geometry. 
On the other hand, circular interpolation tests with small radii 
(e.g. with the KGM) provide information on the accuracy of the 
control under high axis acceleration. The influence of the 
machine geometry on the result of measurement is insignificant. 
The control and drives, however, have a strong effect. 
 
• Free-form test with the KGM 
In the free-form test, the CNC control moves the machine axes 
in a plane on any programmed path. The corner test, for 
example, provides information on the dynamics of the position 
control loops with respect to overshoot and the resulting 
rounding error. Free-form tests can be conducted only with the 
KGM grid encoder. 
Special free-form contours can be evaluated according to ISO 
10791-6 K2—Feeds and K3—Interpolation. 
 
• Step response test with the KGM and VM 182 
The step response test can be used to measure the overshoot 
behavior in an axis (step-response function) and provide 
information on the influence of static friction and the accuracy 
with which positions can be held. This test is also intended for 
high-precision tasks requiring increments of as small as 0.1 µm 
to 0.01 µm. Step response test with can be performed with the 
KGM grid  encoder or the VM 182. 
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Static measurements 
Static measurements, such as the measurement of position 
error in the linear axes using a comparator system, permit 
conclusions exclusively on the geometric accuracy of the 
machine. 
 
• Measuring the static positioning accuracy and guideway 
error with the KGM and the VM 182 
The positioning accuracy and repeatability of a machine tool is 
measured statically after the machine axis has been moved to 
certain positions. Besides the positioning accuracy, these 
devices also measure the guideway error perpendicular to 
the direction of machine tool traverse. The KGM can inspect 
accuracy in two axes within traverses up to 230 mm; the 
VM 182 can inspect larger traverses up to 1520 mm parallel 
to one axis. 
 
• Measuring the static positioning accuracy with an angle 
encoder, such as the RON 905, RPN880, RON880 or the 
ROD 880 
The positioning accuracy and repeatability of a machine tool is 
measured statically after the machine axis has been moved to 
certain positions. 
 

Items supplied with the ACCOM evaluation software for PCs 
The PC evaluation software ACCOM consists of: 
• One setup CD 
• One hardware key (ld. Nr. 590255-01 or 590255-02) to be 

plugged into a free USB interface 
 

General conditions for use of the software 
• By paying the purchase price, the purchaser does not acquire 

the program itself but only a temporally unlimited right to use 
the program. 

• The buyer is permitted to make copies of the CD only for 
backup purposes and to copy it to a hard disk. It is prohibited 
to sell such copies to a third party. 
All rights of possession are retained by the manufacturer. 

• The transfer of the right to use the program to a third party 
requires the express written consent of the manufacturer. 
The transfer cancels the right of use for the original buyer. All 
backup copies must either be given along with the originals 
or destroyed without delay, and the manufacturer must be 
informed of this accordingly. 

• The manufacturer is not responsible for damages of any kind 
that might result from the use of this program.  
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Hardware and operating system 
• PC/Notebook as of Pentium III 1 GHz (or higher) with 256 MB 

RAM (XP), one free USB port and optional one Ethernet port. 
• Windows 7/8 / Vista / XP / 2000 operating system (The PC 

hardware requirements for Windows 7/8 / Vista are much 
higher than for ACCOM.) Windows 7/8 64Bit operating 
system is supported as well.  

• Approx. 18 MB free space on the hard disk 
• To enable the PC to process measured values, the EIB 741 

or IK 220 counter card for PCs must be installed according to 
the User’s Manual. You need a separate Ethernet port for the 
EIB 741. 

 
 

 

Ensure that the screen saver and energy savings 
functions are deactivated. 

Note 
ACCOM can be operated either with the mouse or the 
keyboard.  
 

Installation 
To install the ACCOM evaluation software on the hard disk of 
your PC, take the following steps: 
 
 Insert the CD in the drive. The setup program should start 
automatically (setup.exe can also be started from the Windows 
Explorer). 
 
 Select the language and follow the instructions on the 
screen. The program is installed in the folder that you select. An 
ACCOM program group is created which includes the link 
symbol for the application. 
 
 The driver for the hardware key must be installed separately. 
Click the hardware-key icon in the setup window. 
 
  Install the driver for the IK 220 according to the User’s 
Manual. The IK 220 driver for Windows 7/8 / Vista is part of the 
ACCOM CD. 

Note 
If you would like to put the link icon on the desktop (opening 
screen of Windows), click a free space on the screen with the 
right mouse key and use New > Link to make the program icon. 

10 HEIDENHAIN 



 Introduction 

Measuring sequence 
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ACCOM program start 
 
 Open the ACCOM window in the program manage 
 Click twice on the ACCOM symbol 
 

 
 

Select measuring method 
 
KGM circular test  Here you can select a circular test measurement using the  

KGM 181 with measuring radii of 1 µm to 60 mm, or the 
KGM 182 with measuring radii of 1 µm to 110 mm. This 
measurement is calculated and evaluated according to the 
internationally valid standard ISO 230-4. 

 
KGM free-form test  Here you select a free-form test with the KGM 181 or KGM 182. 

A free-form test enables you to program and then measure any 
contour, for example a simulated NAS workpiece in a plane. 
In addition, you can enter and evaluate two special free-form 
contours according to ISO 10791-6 for the measurement of feed 
accuracy (K2) and the interpolation of two axes (K3). 

 
VM linear test Here you select a linear measurement using the VM 101, VM 182, 

KGM 181 or KGM 182. This measurement can determine the 
static positioning accuracy of a machine. It ascertains and 
calculates positioning accuracy according to the internationally 
valid standard ISO 230-2, ISO 230-3 or the German national 
standard VDI/DGQ 3441. 
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Rotatory test Here you select a rotatory measurement using with a HEIDNEHAIN 
angular encoder, e.g. a RON 905, a RPN 886, a RON 886 or a 
ROD 880. This measurement can determine the static 
positioning accuracy of rotary axes. It ascertains and calculates 
positioning accuracy according to the internationally valid 
standard ISO 230-2, ISO 230-3 or the German national 
standard VDI/DGQ 3441. 

 
DBB circular test  Here you select a circular test with the DBB 110 for radii of 150 

to 350 mm. This measurement is calculated and evaluated 
according to the internationally valid standard ISO 230-4. 

 
 
 

Home window—description of the symbols 
 
In the home window of the ACCOM user interface you can 
select the functions of ACCOM in the menu bar through “pull-
down menus,“ or select the most frequently needed functions 
directly in the toolbar. 
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Select Measuring Method 
Here you can select from among the individual measuring 
methods. 

(File > Select measuring method) 
 
 
Open Measurement 
Here you can directly call up measurements (all measuring 
methods) that have been saved. 

(File > Open measurement) 
 
 
Saving a measurement 
Here you can save measurements (all measuring methods) as 
files. 

(File > Save measurement) 
 
 
Print 
Here you can print the active graphic or the active evaluation 
window (all measuring methods). 

(File > Print) 
 
 
Calibration chart 
Here you can select a calibration chart (all measuring methods) 
for measurement of individual entries. 

(Measure > Calibration chart) 
 
 
Start measurement 
Here you can start a measurement (all measuring methods). 

(Measure > Start measurement) 
 
 
 
Start measurement 
Here you can start a measurement series (KGK—measuring 
method). 

(Measure > Start series of measurements) 
 
 
Configuring the graphics for KGM circular tests using DBB 
and KGM 
Here you can select the menu for configuring the graphics 
during circular measurements using the DBB 110 or KGM. 

(Evaluate > Graphic) 
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Configuring the graphics for KGM free-form measurements 
using the KGM 
Here you can select the menu for configuring the graphics 
during free-form measurements using the KGM. 

(Evaluate > Graphic) 
 
 
Configuring the graphics for VML linear tests using KGM 
and VM 
Here you can select the menu for configuring the graphics 
during VM linear measurements using the VM or KGM. 

(Evaluate > Graphic) 
 
Select raw data 
Here you can select the raw data (all measuring methods) of 
the recorded measurements. In the raw data ACCOM shows 
the X/Y position values of the recorded measurement. 

(Evaluate > Raw data) 
 
Select characteristic data 
Here you can select the characteristic data (DBB, KGK, VML 
measuring methods and the ISO 10791-6 measurements in 
KGF) of the recorded measurements. The characteristics also 
show calculations according to international standards. 

(Evaluate > Characteristic data) 
 
Parameters of measurement 
Here you can select or change the parameters of the 
measurement (all measuring methods). 

(Options > Parameters of measurement) 
 
 
Connect the EIB 741 
Here you can connect the EIB 741 via TCP/IP. 

(Options > Counter card > Connect) 
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Measuring Procedure for KGM Circular Test (KGK) 

Machine cleaning 
 Before beginning to mount the KGM, clean the area of the 
machine tool in which the measurements are made. Pay special 
attention to any chips and oil or grease residue that could fall 
onto the encoder. 
 

 

 
Give the encoder time to adjust to the ambient 
temperature before you begin mounting it. This will help 
to prevent thermally induced error. 

 
Test program 

To best enable the software to calculate and assign all error,  
a circular test should include at least one complete circle in 
positive direction and one in negative direction (see ISO 230-4). 
With HEIDENHAIN controls, the machine program can be 
transferred directly from ACCOM. For non-HEIDENHAIN 
controls, a typical test program could be as follows, whereby 
movement must be measured only in the measuring plane. 
 
Part 1, positive direction: Motion without interruption from the 
circle center to the circumference at 0°, then a closed circular 
movement over 720° in counterclockwise direction, then back to 
the circle center, followed by 10 seconds wait if it is a series of 
measurements. For single measurements, the spindle stops 
instead of waiting, and you must save the results between 
measurements. 
Part 2, negative direction: Motion without interruption from the 
circle center to the circle circumference at 0°, then a closed 
circular movement over 720° in clockwise direction followed by 
movement back to the circle center, where the spindle stops. 
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Ensure that there are no “forgotten” compensation data 
saved in the control that could cause a movement 
perpendicular to the encoder or corrupt the measurement. 
The spindle must not rotate. If necessary, ask your 
machine tool builder how it can be fixed. You might try 
running the machine program without the encoder. 

 
Measuring assembly 

 Ensure that the IK 220 PC counter card was installed in your 
PC according to the instructions in the User’s Manual. 
Alternatively you can use the EIB 741. Please ensure an 
available peer-to-peer network connection to the EIB 741 
(address and subnet mask of the TCP/IP connection). 
Now mount the KGM according to the instructions in the 
manual.  Do not use any screws for mounting whose heads 
project above the height of the cross grid! 
 

 

 
When connecting the measuring cables, be sure to leave 
enough slack to compensate any machine movement 
during measurement. 

 
 Before starting ACCOM, connect the enclosed hardware 
key with ld. No. 590255-01 or 590255-02 to one free USB port. 
 
After calling ACCOM, proceed as follows: 
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1. Select measuring method 
After ACCOM is started, a dialog box appears in which you can 
select the type of measurement. 
 
 Click the KGM circular test button to start the corresponding 
program part. 
 
With the menu item File > Select measuring method or by 
clicking the icon you can select the individual measuring 
methods from within the running program.  
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2. Specifying the unit of measure 
 With the menu item  Options > Unit of measurement  you 
specify the desired unit of measure. Close the dialog box with 
OK. 
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 Measuring Procedure for KGK 

3. Settings of the encoder and the counter card 
 Under  Options > Measuring interface  you set the 
parameters for the encoder used. 
• Signal period: Here you set the signal period (as its distance 
in µm) of the encoder you are using. The default setting for the 
signal period is 4 µm. 
Input range:  0.1 to 20 µm 
 

 
 
 Under  Options > Counter card  you set the parameters for 
the PC counter card. 
• Type counter card: Here you select the model of counter 
card that you are using. 
• Signal input: Here you select the type of measuring signal. 
• Address EIB 741: Here you enter the IP address of the EIB 
741 (see also EIB 741 user manual). Alternatively you may use 
the DHCP hostname in a company network. However it is not 
recommended due to the high data acquisition rate. 
This setting is not needed for the IK 220. 
• Automatic connection at program start: ACCOM connect 
to the EIB 741 at the next program start automatically if chosen. 
A valid connection to the EIB 741 is required! 
• Test IK (IK 220 only): Here you can then test the counter 
card for proper function.  
• Connect/Disconnect (EIB 741 only): The EIB 741 will be 
connected or disconnected here. 
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Ensure that you have entered the proper model, address 
and signal input of the counter card. If the signal period is 
entered incorrectly, the circles will be measured too large 
or too small. 

 
Note 

EIB 741 only: Connect the KGM to the encoder inputs X11 and 
X12. 
 

 

 
If you have problems receiving data from the counter 
card, use the test programs on the driver CD to check 
whether the counter card or external interface box can be 
used. 
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4. Fine adjustment of the measuring head 
 

Oscilloscope 
 With the menu item Equipment > Oscilloscope you can 
display the KGM measuring signals received by the PC counter 
card as Lissajous figures on the screen, which you need for the 
fine adjustment of the KGM (see mounting instructions of the 
KGM). 
 

 
 
The measuring signals are displayed for the directions I and II in 
the oscilloscope display mode (for measuring signals 0° elec. 
and 90° elec.). 
 
 Move the machine tool slide slowly and evenly in diagonal 
direction. Use the adjusting screws on the measuring head to 
adjust the signal amplitude. In the ideal case, the measuring 
signal amplitude lies near the green circular path (1 VPP) 
between the red limit circles. 
 
If the encoder signal is too large or small, the message 
Amplitude too high / too low appears in the status line of the 
ACCOM screen. 
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Optimizing the measuring signals 
 Through automatic signal adjustment, ACCOM can optimize 
the measuring signals to attain very high accuracy. Click the 
boxes Compensation X1 (X11) and Compensation X2 (X12) 
and move the machine slides slowly and evenly in diagonal 
direction. Then switch this function off by clicking both boxes 
Compensation X1 (X11) and Compensation X2 (X12) again, 
and go to the next item of the instructions. The EIB 741 
optimizes the analogue signals automatically. However, the 
optimized analogue signals are used only for the computation of 
the position values. Therefore it is possible to observe imperfect 
circular Lissajous figures. 
 

 

 
If the displayed signal amplitude is too low, check 
whether the settings for the interface are correct and 
whether the encoder is correctly installed. Then start 
ACCOM again. Do not engage or disengage any 
connectors until you have exited ACCOM! 

 
 

Position display 
 With the menu item Equipment > Position display you can 
call the position display for the connected encoder and, for 
example, check the positive counting direction of the KGM. If 
you call this function after setting the position (see section 8, 
“Set datum”), before the test you should check again whether 
your datum is set correctly and, if not, enter it again. 
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5. Parameters of the measurement 
 By calling the menu item  Options > Parameters of the 
measurement  or by clicking the icon, you open the following 
dialog box in which you can adjust the parameters of the 
measurement. 
 

 
 
• Measuring plane: The machine tool’s working plane in which 
the measurement is to be made. 
• Amount of points: Number of measuring points per 
measurement. 
Input range: 36 to 8000 measuring points 
• Starting angle: Here you enter the angle from which ACCOM 
is to begin the measurement. 
Input range:  0 to 360 degrees 

Note 
Since the orthogonality of the axes is measured at 45°, and the 
axis reversal movements occur at the quadrant transitions (0°, 
90°, 180°, 270°), a starting angle of 30° is recommended. 
 
• Measuring angle: Here you enter the angle over which the 
measurement is to be made. 
Input range:  1 to 720 degrees 

Note 
An angle of at least 360° is required for a complete calculated 
evaluation of a circular test. 
 
• Radius: Here you enter the nominal radius of the circle.  
Input range:  0.01 to 10 000 mm 
   0.0003937 to 3937 inches 
 
 Then conclude the input with OK. 
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6. Setting the NC interface 
 If you wish to transfer the measuring program in ACCOM to 
a HEIDENHAIN control, select  Options > NC programming  to 
open a dialog box in which you can configure the network 
connection. 
 

 
 
• Mode: Choose between HEIDENHAIN or ISO format. 
• Feed rate: Here you enter the nominal feed rate for the 
circular motion. 
Input range:  0.001 to 100 000 mm/min or 
   0.000 04 to 3900 inches/min 
• Program name: Here you give the program a name (the 
extension .H stands for HEIDENHAIN, .I stands for 
HEIDENHAIN ISO and .txt for general ISO). 
• Decimal place: Select the decimal place of the NC programs. 
• M functions: Here you enter additional M functions which are 
necessary to run the NC program on the control. 
The M functions are added to the first NC block. 
Example in HEIDENHAIN conversational programming:  
2 L X0 F1000 M31 
• TCP/IP address: Here you enter the TCP/IP address or 
DHCP hostname of the control for the data transfer via network 
connection. 
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G-Code options 
 
 By clicking the control button Options the following dialog 
box opens. Here you can configure some ISO format settings 
which are suitable to the control.  
 

 
 
• Position (export only): This parameter is used in the export 
of an ISO NC program only. For absolute positions G90 is 
added at the NC program start, for incremental positions G91 is 
used.  
For absolute programming it is useful to add a datum shift (e.g. 
G54). 
• Circle center: The input of the circle center point acc. to the 
German standard DIN 66025 is done incremental to the last 
position or absolute. Usually I, J, K are used with incremental 
positions. Valid is also an absolute position with I, J, K. 
(depends on the control). 
• Feed rate: This parameter is only valid for an INCH program. 
The feed rate can be set in Inch/Min or Inch/10Min 
(HEIDENHAIN default). 
• G-code for Inch/MM: You can choose whether to use 
G71/G70 for NC programs or not. 
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In the dialog box Parameters for NC-programming you may 
add the following data for the ISO format programming: 
• Additional lines at program start: Here you can add 2 user 
or control specific lines at program start (e.g. G54). 
• Additional lines at program end: Here you can add 2 user 
or control specific lines at program end (e.g. M30). 
 
 

Network cable 
 
 Connect the TNC by a (crossed) network cable directly to the 
PC or by using a standard network cable with a hub or a switch 
to the company network. 

Note 
Peer-to-peer (direct connection): You need to set the IP-
Address of the PC in Control Panel / Network / TCP-IP / 
Properties (depends on the operating system). As default the 
value for the IP-Address will be given automatically in a 
company network (from the DHCP Server). 
 
 
LAN (Network) with a 1:1 cable 

 
 
 
Peer-to-peer (direct connection) with a (crossed) cable! 
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7. Setting the Direction 
 Before the first measurement with the KGM, ACCOM must 
know the positive counting direction of each axis as well as the 
angular position of the KGM on the machine table. In the menu 
item  Measure > Directions, ACCOM prompts you to move the 
machine slides in sequence in the direction shown in the dialog 
box. The directions depend on the setting of the measuring 
plane (see positive direction I and II on the KGM). The required 
accuracy data is calculated from the signals of the encoder 
(channel assignment, counting direction and angular position). 
 

 
 

Note 
You can specify which traverse path is to be used to detect the 
first direction and, at the same time, the angular position. The 
larger the path, the more accurate is the angular position. For 
very high accuracy requirements you can use the entire 
maximum available traverse on the KGM. The traverse path for 
the second direction is set to 0.1mm and is used only to get the 
direction of the second machine axis.  
 

 

 
During the directional detection, do not move the 
machine tool slide in a diagonal direction. Otherwise the 
detected angular position will be incorrect. 
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8. Set datum 
 In the menu item Measure > Set datum you assign ACCOM 
a position value in agreement with the control. 
Example: 
If the spindle (scanning head) is located over the center of the 
KGM grid plate, you assign the coordinates X0 and Y0 to this 
position. 
 

 
 

Last initialization 
After you have started ACCOM you can use your previous 
settings by calling the menu item  Measure > Last initialization, 
provided that the setup of the KGM on your machine has not 
changed and you move the scanning head to the position last 
set. Then continue with the next program item. 
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9. Generating and transferring an NC program for single measurement 
 If you wish to generate and transfer an NC program for 
single measurements (for measurement series see section 
11a.1. “Edit Series of Measurements”), call the menu item File > 
Upload NC program to TNC, and select the form in which you 
would like to transfer the NC program. 
 

 
 
• Generate according to options: This button calls a dialog 
box entitled Generate NC program for measurement in which 
you define the parameters for the NC program. 
• Load from file (TCP/IP): In the TCP/IP operating mode, a 
finished NC program is transferred from the file system of your 
PC to the NC control by a network connection. 
 

Note 
Alternatively you can use the HEIDENHAIN PC-Tool TNCRemo 
for the data transfer to the control. 
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• Mode: Choose the format of the NC program. 
• Feed rate: Enter here the nominal feed rate of motion. 
Input range:  0.001 to 100 000 mm/min 
   0.000 04 to 3900 inches/min 
• Program name: In TCP/IP mode you add the extension .H for 
HEIDENHAIN format or .I for ISO format to the NC program. 
• Measuring plane: Click the working plane of the machine 
tool. 
• 1. Direction of rotation: Select the direction in which the first 
of the two circular movements defined by the control is to be 
made. 
• Starting angle: Enter here the same starting angle as you did 
before under menu item Parameters of measurement. 
• Measurement angle: Enter here the same measuring angle 
as you did before under menu item Parameters of 
measurement. 
• Radius: Enter here the same radius as you did before under 
menu item Parameters of measurement. 
• Save: Click to save the NC program. 
• Cancel: Click to close the dialog box. 
• Upload: Click to start the upload. 
  
Now an NC program is generated for both directions of rotation 
and transferred in default settings to the root directory of the 
TNC. Data transfer via TCP/IP opens a new file dialog window, 
where you can select the target directory on the control. 
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The following prerequisites must be met for the correct 
execution of the NC program with two circular movements 
in opposite directions.  
1. The datum of the NC program must match the datum 
defined in “Set datum.” 
2. The spindle head must be located at the datum when 
the program starts. 

 
 

 
The TNC does not answer if the network is not 
connected. 
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10. Generating a calibration chart 
 Through the menu item Measure > Calibration chart or by 
clicking the icon you can define the calibration chart for the 
measurement by entering information on the measurements in 
the calibration window. By clicking yes or no you can specify 
whether the chart window will open automatically after each 
measurement. 
 

 
 
If you enter the chart data only for measurement 1, they will 
automatically apply also to the other measurements. The charts 
can also be saved or edited later in the course of evaluation. 
ACCOM saves these data together with the measured data and 
prints them through the menu items Evaluate > Measured data, 
Evaluate > Characteristic data and Graphic > Print. 
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11a.1. Edit series of measurements 
 If you would like to make two or more measurements in 
sequence, you can use Measure > Edit series of 
measurements to list a series of measurements that are 
performed together. In this case it is best to give the machine 
tool a break of approx. 10 sec. between the measurements in 
the series. 
If you would like to make only single measurements, you can 
skip this section and go directly to section 11b of this Manual. 
 

 
 
• Name: Here you can enter a name. 
• Graphics: Enter here the resolution for displaying the circular 
form. You can change the resolution at any time during the 
evaluation. 
 

 

 
When you change the resolution you also change the 
window for starting the measurement (criterion for start of 
measurement: nominal radius ± 5 x resolution). 

 
• Repeat series of measurements: With this function you can 
repeat a series of measurement as often as desired and 
overwrite the old measuring data; this is intended for use, for 
example, in sales presentations and trade shows. 
• Insert: After clicking this button you can specify the 
measuring parameters of the individual series of measurements 
and in this manner determine the automatic execution of the 
measurement program: 
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• Measurement No.: The measurement is displayed later 
under this number. In the subsequent graphic evaluation no 
more than four motion error traces can be displayed at once. 
• File name: Each measuring line must be given its own name 
under which the results can then be automatically saved. 
• Feed rate: Here you enter the nominal feed rate for the 
movement. 
Input range:  0.001 to 100 000 mm/min or 
   0.000 04 to 3900 inches/min 
• Offset of circle center: Here you can shift the circle center 
with respect to the datum selected under Set datum. 
• Direction of rotation: Here you enter the direction of rotation 
of the circle to be measured. For a complete computational 
evaluation of a circular test you always need two circles with 
equal radius and feed rate and opposite direction of rotation. 
• Radius: Here you enter the nominal radius of the circle.  
Input range:  0.01 to 10 000 mm 
   0.0003937 to 3937 inches 
• Starting angle: The angle at which ACCOM starts to record 
the measurement. A start angle of 30° is recommended in order 
not to hamper the orthogonality measurement (at 45°) and the 
reversal motion of the machine axes (at 0°, 90°, 180°, 270°). 
Input range:  0 to 360° 
• Measuring angle: Here you enter the angle over which the 
measurement is to be made. A complete computational 
evaluation requires at least 360°. 
Input range:  1 to 720° 
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• Amount of points: Number of measuring points per 
measurement. 
Input range: 36 to 8000 measuring points 
• Print: Here you can specify whether and in what form you 
wish to print the results between measurements. 
You can always print the results after the measurements. 
Choices:  No printout 
   Graphic 
   Measurement data 
   Characteristic values 
 You then confirm your entry with OK. 
 
• File path: Select here the folder in which subsequent 
measurements are to be saved. Do not enter a file name here. 
You have already specified that in the single measurement. 
 

 

 
The OK button of the dialog box remains disabled until 
you select the file path. 
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• Edit: This button calls the dialog box illustrated below in which 
you can edit existing parameters of measurement settings. 

 

 
 
After editing the parameters, close the dialog box by clicking 
OK. 
 
• Delete: To delete existing measurement settings, select the 
row and click this button. 
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• Save measuring script: This button calls the following dialog 
box in which you can save the measurement series. 
 

 
 
• Open measuring script: This button calls the following dialog 
box in which you call a file containing a measurement series. 
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• Generate NC program: This button opens a dialog box in 
which you can generate an NC program for the series of 
measurements. 
 

 
 
• Mode: Choose the format of the NC program. 
• Program name: In TCP/IP mode you add the extension .H for 
HEIDENHAIN format or .I for ISO format to the NC program. 
• Measuring dwell time: Here you enter the dwell time 
between the measurements. 
• Save: Click to save the NC program. 
• Cancel: Click to close the dialog box. 
• Transfer: Click to start the upload. 
 
Now an NC program is generated for the measurement series 
and transferred to the root directory of the TNC in the default 
setting. Data transfer via TCP/IP opens a new file dialog 
window, where you can select the target directory on the 
control. 
 

 

 
The following prerequisites must be met for the correct 
execution of the NC program.  
1. The datum of the NC program must match the datum 
defined in “Set datum.” 
2. The spindle head must be located at the datum when 
the program starts.   
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The TNC does not answer if the network is not 
connected. 

 
 When you have completed all entries, close the dialog box 
with OK. 
 

11a.2. Start series of measurements 
 With the menu item  Measure > Start series of 
measurements or by clicking the associated button you can now 
begin the measurement. ACCOM waits for the beginning of 
measurement. Start the program on the machine tool. 
 
In the status line, ACCOM shows the condition of 
measurement. You can terminate the measurement at any time 
with Cancel. After the measurement has ended the results are 
saved automatically under the name of the measurement series 
in the file path that you have specified. 
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If ACCOM does not begin measuring although the 
circular movement was made on the machine tool, wait 
for a period of 15 to 30 seconds after the movement 
ends. If the menu item  Evaluate > Graphic > 
Representation  was set to Center or Radius 
compensation (see point 16, Graphic Display of Circular 
Test Results), there is no online display.  If after some 
time there is no result, check whether the circle center, 
feed rate and radius of the NC program agree with the 
values specified in ACCOM. Pay special attention to any 
offset of the circle center. 

 
 

11b. Start Single Measurement 
 If you want to take only individual measurements, select the 
menu item Measure > Start measurement or click the 
associated button to open a dialog box with which you can start 
measurements after entering the following parameters. 
 

 
 
• Measurement 1-4: Click the number under which the 
measurement is to be shown later. 
• Direction of rotation: Select here the direction of rotation for 
the circular movement. 
 
• Feed rate: Enter here the nominal feed rate of motion. 
Input range:  0.001 to 100.000 mm/min 
   0.000 04 to 3900 inches/min 
• Graphics: Enter here the resolution for displaying the circular 
form. You can change the resolution at any time during the 
evaluation. 
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Input range:  0.1 to 10.000 µm/div. 
0.000 04 to 0.4 inches/div. 

 
 

 
When you change the resolution you also change the 
window for starting the measurement (criterion for start of 
measurement: nominal radius ± 10 x resolution). 

 
Note 

A complete circular test according to ISO 230-4 is supposed to 
include two complete circles of the same radius, center, and 
feed rate, but with different direction of rotation. 
 
 Start: After you click this button, ACCOM waits for the 
beginning of measurement. Start the circular movement on the 
machine tool. In the status line, ACCOM shows the condition of 
measurement. You can terminate the measurement with 
Cancel. 
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Note 
If ACCOM does not begin measuring although the circular 
movement was made on the machine tool, wait for a period of 
15 to 30 seconds after the movement ends. If the menu item  
Evaluate > Graphic > Representation  was set to Center or 
Radius compensation (see point 16, Graphic Display of Circular 
Test Results), there is no online display.  If after some time 
there is no result, check whether the circle center, feed rate and 
radius of the NC program agree with the values specified in 
ACCOM. Pay special attention to any offset of the circle center. 
 

Data storage 
After conclusion of measurement, the following dialog box 
appears for data storage. 
 

 
 
With Measure > Start measurement you can start further 
measurements. 
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12. Open measurement 
 Through File > Open measurement  or by clicking the 
associated button you can load the measured data for further 
evaluation and display. The following screen appears. 
 

 
 
Since up to four measurements can be shown simultaneously, 
this dialog box enables you to open the measurements in any 
sequence. 
This menu item also enables you to call other motion error 
traces to the screen for further evaluation.   
 

 

 
The results of measurement are loaded into the system 
with menu item Open measurement. This is a prerequisite 
for display. Through the menu item Evaluate > Graphic 
you can influence how and whether the motion error 
traces are displayed (see also section 16, “Graphic 
Display”). 
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13. Evaluate measured data 
 You can view the raw measurement data through the menu 
item Evaluate > Raw data or by clicking the associated symbol. 
ACCOM shows every measured deviation including the 
associated angle. 
 

 
 

Note 
The ACCOM data is saved in an ASCII file. The raw data are 
saved line by line, separated by tabs. You can load or import 
this file for further processing in other programs like Matlab, 
Origin, Microsoft Excel or Open Office. 
 
To print the raw data, click the print symbol. 

 
If you click Cancel, the dialog box closes. 
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14. Select standard for evaluation 
 In the menu item  Evaluate > Standard  you can select the 
guideline for evaluating the circular test. At present only the ISO 
230-4 standard is available. 
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15. Characteristic Data of the Circular Test 
 With the menu item  Evaluate > Raw data,  or by clicking the 
associated symbol, you can call the accuracy data calculated 
from the measured data according to ISO 230-4. In addition, 
ACCOM calculates the mean radius, the backlash, the reversal 
peaks, and center deviation and the orthogonality (squareness) 
of the axes. 
 

 
 

 

 
Two circles are required—once each in positive and 
negative direction—for complete calculation of all 
accuracy data, particularly the circular backlash H. 
ACCOM issues a warning if you have forgotten to load 
the second file. 

 
To print the accuracy data, click the print symbol. 
 
If you click Cancel, the dialog box closes. 
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16. Graphic display of circular test results 
 You can specify the display mode of the motion error traces 
through the menu item  Evaluate > Graphic  or by clicking the 
associated symbol.  
 

 
 
• Release: Here you can select up to four previously opened 
measurements to be displayed. 
 
You can choose in principle between circular and linear 
diagrams and configure the respective settings. Scaling can 
then either be set to a fixed value or can be selected 
automatically by the system. 
 
• Scaling of the circular graphic: In the circular graphic you 
can set the desired resolution. 
Input range of resolution: 0.1 to 10 000 µm 
    0.000 004 to 0.4 inch 
• Scaling of the linear graphic: In linear graphics you can set 
the upper and lower limit or the displayed angular range for the 
deviations from an ideal circular path. 
Error from/to:  –10 000 to +10 000 µm 
    –0.4 to 0.4 inch 
Angle from/to:  0 to 360° 

ACCOM 51 



Measuring Procedure for KGK 

• Representation:  
Center: With this function you can display a centered view 
of the measurement  ACCOM shows you the calculated 
actual circle center. 
Radius compensation: Here the radius error is 
compensated by ACCOM in the graphic and displayed in 
the box. 

 
 

 
Before measuring you should switch off the centering 
and radius compensation function, since otherwise the 
graphic will not be shown online. 

 
You have the choice between the following display modes:
   Circle large 
   Circle small 
   Linear large 
 
• Circle large: Here, ACCOM draws up to four motion error 
traces in one circular graphic. You can switch the error traces 
on and off with the menu item  Evaluate > Graphic > Release 
measurement 1-4. 
The nominal radius is shown as a dotted line in the 
measurement graphic. 
The largest and smallest radius errors are shown as a 
dashed line in the graphic. 
 

 
 
You can load new measurements with File > Open 
measurement or by clicking on the associated button. 
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• Circle small: Here, ACCOM draws each motion error traces 
in a separate circular graphic. You can switch the error traces 
on and off with the menu item  Evaluate > Graphic > Release 
measurement 1-4. 
 

 
 
You can load new measurements with File > Open 
measurement or by clicking on the associated button. 
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• Linear large: Here, ACCOM draws up to four motion error 
traces in one linear graphic. You can switch the error traces on 
and off with the menu item  Evaluate > Graphic > Release 
measurement 1-4. In the example the scaling is fixed and the 
angle of 0 to 360° is selected. 
 

 
 
As an alternative you can also display an angular range. In the 
example the scaling is fixed and the angle of 80 to 100° is 
selected. 
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Additional circular test options 
 
 By clicking on the control button Options the following dialog 
box opens. Here you can set additional display options. 
 

 
 
• Display options for circle large/small: In the circular test 
graphic you can disable the auxiliary lines for the minimum and 
maximum radius deviation and/or the scaling values. 
• Special options for circle large/small: In the default graphic 
for the circular test the first measurement axis is shown right 
and the second axis is shown top. Alternatively the axis can be 
displayed mirrored (1st axis top, 2nd axis right). The third 
display option is: 1st axis is shown top and 2nd axis is shown 
left (axes are turned by 90 degrees).  
• Special option linear large: Alternatively you may use a 
path-time diagram for the radius deviation (time instead of 
angle). 
• Save circular test options: Here the special options for the 
circular test representation can be saved (at program end or 
change of measurement type). 
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DTA-file import 
You can transfer a circular measurement from a new 
HEIDENHAIN control by using the menu item File > DTA file 
import or File > DTA file download > via TCP/IP  and evaluate it. 
 
Requirements for the DTA import: 
• The recorded measurement has two different channels for the 
circular measurement (e.g. X and Y) 
• The internal oscilloscope uses the circular mode (CIRC). 
• You need two channels with the data contour deviation 
(channel 32). 
• Start and end of the measurement have to be (0/0). 
 

 
 
• Scaling: Enter here a resolution suitable for transferring the 
DTA file. 
• Rotation: The direction of rotation is calculated from the 
measured data. 
• Starting angle: The starting angle is calculated from the 
measured data. 
• Meas. angle: The measurement angle is calculated from the 
measured data. 
• Radius: Here you enter the nominal radius for the imported 
measurement data. At first, the maximum radius is calculated 
from the measured data and entered. 
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• Feed rate: Enter the nominal feed rate for the imported 
measurement data. 
• First measuring point: Enter the first measuring point to be 
transferred for the circular measurement. 
• Last measuring point: Enter the last measuring point to be 
transferred for the circular measurement. 
 
 Accept  Click this button for ACCOM to adopt the imported 
DTA file as a circular measurement. It can now be saved and 
evaluated as an ACCOM circular measurement. 
 

Color settings of the graphic 
If you would like to change the color setting of the graphics, 
you can change the color of the error traces, of the coordinate 
system and the graphic background with the menu item  
Options > Color setting. 
 

Saving/loading the options 
You can save these settings with the menu item  Options > 
Save options. 
You can call these settings with the menu item  Options > Load 
options. 
 

Exporting the measurement graphic 
If you wish to export the measured graphic as a file without a 
log, you can save it as a bitmap using the menu item Graphic > 
Save. 

Printing the graphic 
You can print the graphic with the menu item Graphic > Print. 
You can change the printer settings through the menu item 
File > Printer setup. 
 

Editing the calibration charts 
If you would like to edit the calibration charts you can select 
the desired chart through the menu item Measure > Calibration 
chart or by clicking the associated symbol. 
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Saving a measurement 
If you make changes to a calibration chart, you can save 
them through the menu item  File > Save measurement  or by 
clicking the save button. 
As an alternative, you can also save the measured data through 
the menu item  File > Save all measurements. 
 

Clearing the screen 
To remove the motion error traces from the screen, you can 
clear the screen with the menu item  Graphic > Close. 
 
 

58 HEIDENHAIN 



 Measuring Procedure for KGF 

Measuring Procedure for KGM Free-Form Test (KGF) 

Machine cleaning 
 Before beginning to mount the KGM, clean the area of the 
machine tool in which the measurements are made. Pay special 
attention to any chips and oil or grease residue that could fall 
onto the encoder. 
 

 

 
Give the encoder time to adjust to the ambient 
temperature before you begin mounting it. This will help 
to prevent thermally induced error. 

 
Test program 

In the free-form test, the CNC control moves the machine axes 
in a plane on any programmed path. The corner test provides 
information on the dynamics of the position control loops with 
respect to overshoot and the resulting rounding error. You can 
also test workpieces of any contour on the grid plate to obtain a 
first impression of the contour accuracy to be expected within 
the measuring plane without first having to machine a 
workpiece. 
Free-form contours according to ISO 10791-6 K2—Feeds and 
K3—Interpolation of two axes can be measured in the KGM 
free-form test. 
 
On machine tools with HEIDENHAIN controls, the machine 
program can be transferred directly from ACCOM. For machine 
tools without HEIDENHAIN controls, the NC program must be 
written manually, whereby movement must be measured only in 
the measuring plane. 
 

 

 
Ensure that there are no “forgotten” compensation data 
saved in the control that could cause a movement 
perpendicular to the encoder or corrupt the measurement. 
The spindle must not rotate. If necessary, ask your 
machine tool builder how it can be fixed. You might try 
running the machine program without the encoder. 
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Measuring assembly 
 Ensure that the IK 220 PC counter card was installed in your 
PC according to the instructions in the User’s Manual. 
Alternatively you can use the EIB 741. Please ensure an 
available peer-to-peer network connection to the EIB 741 
(address and subnet mask of the TCP/IP connection). Connect 
the KGM cables to X11 and X12 of the EIB 741. 
Now mount the KGM according to the instructions in the 
manual.  Do not use any screws for mounting whose heads 
project above the height of the cross grid! 
 

 

 
When connecting the measuring cables, be sure to leave 
enough slack to compensate any machine movement 
during measurement. 

 
 Before starting ACCOM, connect the enclosed hardware 
key with ld. No. 590255-01 or 590255-02 to one free USB port. 
 
After calling ACCOM, proceed as follows: 
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1. Select measuring method 
After ACCOM is started, a dialog box appears in which you can 
select the type of measurement. 
 
 Click the KGM free-form test button to start the 
corresponding program part. 
 
With the menu item File > Select measuring method or by 
clicking the icon you can select the individual measuring 
methods from within the running program. 
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2. Specifying the unit of measure 
 With the menu item  Options > Unit of measurement  you 
specify the desired unit of measure. Close the dialog box with 
OK. 
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3. Settings of the encoder and the counter card 
 Under  Options > Measuring interface  you set the 
parameters for the encoder used. 
• Signal period: Here you set the signal period (as its distance 
in µm) of the encoder you are using. The default setting for the 
signal period is 4 µm. 
Input range:  0.1 to 20 µm 
• Signal source: Select the model of encoder being used. 
• Count direction 2nd axis to 1st axis (VM 182 only): 
According to the set-up of the VM 182 it can be necessary to 
manually set the count direction for the 2nd axis (orthogonal 
axis). 
• Change measurement axis (VM 182 only): If the VM 182 is 
aligned to the 2nd axis (of the chosen plane) you should check 
this box to get a correct display of the measurement. 
Example: Measurement in XY plane, VM 182 aligned in Y 
direction 
 

 
 
 Under  Options > Counter card  you set the parameters for 
the PC counter card. 
• Type counter card: Here you select the model of counter 
card that you are using. 
• Signal input: Here you select the type of measuring signal. 
• Address EIB 741: Here you enter the IP address of the EIB 
741 (see also EIB 741 user manual). Alternatively you may use 
the DHCP hostname in a company network. However it is not 
recommended due to the high data acquisition rate. 
This setting is not needed for the IK 220. 
• Automatic connection at program start: ACCOM connect 
to the EIB 741 at the next program start automatically if chosen. 
A valid connection to the EIB 741 is required! 
• Test IK (IK 220): Here you can then test the counter card for 
proper function.  
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• Connect/Disconnect (EIB 741 only): The EIB 741 will be 
connected or disconnected here. 
 

 
 

 

 
Ensure that you have entered the proper model, address 
and signal input of the counter card. If the signal period is 
entered incorrectly, the distances will be measured too 
large or too small. 

 
Note 

Only EIB 741: Connect the encoder cables of the KGM/VM to 
the encoder inputs X11 and X12. 
 

 

 
If you have problems receiving data from the counter 
card, use the test programs on the provided driver CD to 
check whether the card can be used. 
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4. Fine adjustment of the measuring head 
 

Oscilloscope 
 With the menu item Equipment > Oscilloscope you can 
display the KGM measuring signals received by the PC counter 
card as Lissajous figures on the screen, which you need for the 
fine adjustment of the KGM (see mounting instructions of the 
KGM). 
 

 
 
The measuring signals are displayed for the directions I and II in 
the oscilloscope  display mode (for measuring signals 0° elec. 
and 90° elec.). 
 
 Move the machine tool slide slowly and evenly in diagonal 
direction. Use the adjusting screws on the measuring head to 
adjust the signal amplitude. In the ideal case, the measuring 
signal amplitude lies near the green circular path (1 VPP) 
between the red limit circles. 
 
If the encoder signal is too large or small, the message 
Amplitude too high / too low appears in the status line of the 
ACCOM screen. 
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Optimizing the measuring signals 
 Through automatic signal adjustment, ACCOM can optimize 
the measuring signals to attain very high accuracy. Click the 
boxes Compensation X1 (X11) and Compensation X2 (X12) 
and move the machine slides slowly and evenly in diagonal 
direction. Then switch this function off by clicking both boxes 
Compensation X1 (X11) and Compensation X2 (X12) again, 
and go to the next item of the instructions. The EIB 741 
optimizes the analogue signals automatically. However, the 
optimized analogue signals are used only for the computation of 
the position values. Therefore it is possible to observe imperfect 
circular Lissajous figures. 
 

 

 
If the displayed signal amplitude is too low, check 
whether the settings for the interface are correct and 
whether the encoder is correctly installed. Then start 
ACCOM again. Do not engage or disengage any 
connectors until you have exited ACCOM! 

 
 

Position display 
With the menu item Equipment > Position display you can call 
the position display for the connected encoder and, for 
example, check the positive counting direction of the KGM. If 
you call this function after setting the position (see section 7, 
“Set datum”), before the test you should check again whether 
your datum is set correctly and, if not, enter it again. 
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5. Parameters of the measurement 
 By calling the menu item  Options > Parameters of the 
measurement  or by clicking the icon, you open the following 
dialog box in which you can adjust the parameters of the 
measurement. 
 

 
 
• Measuring plane: The machine tool’s working plane in which 
the measurement is to be made. 
• Amount of points: Number of measuring points per 
measurement. 
Input range: 36 to100000 measuring points 
• Starting window: Enter here the size of the starting window 
for the motion detection. 
Input range:  0.01 to 100 µm 
   0.000 001 5 to 0.004 inches 
• Standstill window: Enter here the size of the standstill 
window for the computation of the path time. 
Input range:  0.01 to 100 µm 
   4e-7 to 0.004 inches 
 
Conclude the input with OK. 
 
 

Note 
The sampling interval is calculated from the number of 
measurement points and the measurement time. The 
measurement time is shown in the start window (see No.12, 
Start measurement). The measurement time can be set 
manually. 
Example: 40000 measurement points and 4s measurement 
time 

 Sample rate 10kHz 
(Max. sample rate of the EIB 741: 50 kHz,  
Max. sample rate of the IK 220: 10 kHz) 
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6. Setting the NC interface 
 If you wish to transfer the measuring program in ACCOM to 
a HEIDENHAIN control, select  Options > NC programming  to 
open a dialog box in which you can configure the network 
connection. 
 

 
 
• Mode: Choose between HEIDENHAIN or ISO format. 
• Feed rate: Here you enter the nominal feed rate for the 
circular motion. 
Input range:  0.001 to 100 000 mm/min or 
   0.000 04 to 3900 inches/min 
• Program name: Here you give the program a name (the 
extension .H stands for HEIDENHAIN, .I stands for 
HEIDENHAIN ISO and .txt for general ISO). 
• Decimal place: Select the decimal place of the NC programs. 
• M functions: Here you enter additional M functions which are 
necessary to run the NC program on the control. 
The M functions are added to the first NC block. 
Example in HEIDENHAIN conversational programming:  
2 L X0 F1000 M31 
• TCP/IP address: Here you enter the TCP/IP address or 
DHCP hostname of the control for the data transfer via network 
connection.  
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G-Code options 
 
 By clicking the control button Options the following dialog 
box opens. Here you can configure some ISO format settings 
which are suitable to the control.  
 

 
 
• Position (export only): This parameter is used in the export 
of an ISO NC program only. For absolute positions G90 is 
added at the NC program start, for incremental positions G91 is 
used.  
For absolute NC programs it is useful to add a datum shift (e.g. 
G54). 
• Circle center: The input of the circle center point acc. to the 
German standard DIN 66025 is done incremental to the last 
position or absolute. Usually I, J, K are used with incremental 
positions. Valid is also an absolute position with I, J, K. 
(depends on the control). 
• Feed rate: This parameter is only valid for an INCH program. 
The feed rate can be set in Inch/Min or Inch/10Min 
(HEIDENHAIN default). 
• G-code for Inch/MM: You can choose whether to use 
G71/G70 for NC programs or not. 
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In the dialog box Parameters for NC-programming you may 
add the following data for the ISO format programming: 
• Additional lines at program start: Here you can add 2 user 
or control specific lines at program start (e.g. G54). 
• Additional lines at program end: Here you can add 2 user 
or control specific lines at program end (e.g. M30). 
 
 

Network cable 
 
Connect the TNC by a (crossed) network cable directly to the 
PC or by using a standard network cable with a hub or a switch 
to the company network. 

Note 
Peer-to-peer (direct connection): You need to set the IP-
Address of the PC in Control Panel / Network / TCP-IP / 
Properties (depends on the operating system). As default the 
value for the IP-Address will be given automatically in a 
company network (from the DHCP Server). 
 
 
LAN (Network) with a 1:1 cable 

 
 
 
Peer-to-peer (direct connection) with a (crossed) cable! 
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7. Setting the direction 
 Before the first measurement with the KGM, ACCOM must 
know the positive counting direction of each axis as well as the 
angular position of the KGM on the machine table. In the menu 
item  Measure > Directions, ACCOM prompts you to move the 
machine slides in sequence in the direction shown in the dialog 
box. The directions depend on the setting of the measuring 
plane (see positive direction I and II on the KGM). The required 
accuracy data is calculated from the signals of the encoder 
(channel assignment, counting directions and angular position). 
 

 
Note 

You can specify which traverse path is to be used to detect the 
first direction and, at the same time, the angular position. The 
larger the path, the more accurate the angular position. For 
free-form tests, HEIDENHAIN recommends that you exploit the 
maximum available traverse on the KGM. 
 

 

 
During the directional detection, do not move the 
machine tool slide in a diagonal direction. Otherwise the 
detected angular position will be incorrect. 

 

ACCOM 71 



Measuring Procedure for KGF 

8. Set datum 
 In the menu item Measure > Set datum you assign ACCOM 
a position value in agreement with the control. 
 

 
 
 

Last initialization 
After you have started ACCOM you can use your previous 
settings by calling the menu item  Measure > Last initialization, 
provided that the setup of the KGM or VM on your machine has 
not changed and you move the scanning head to the position 
last set. Then continue with the next program item. 
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9. Generating a calibration chart 
 Through the menu item Measure > Calibration chart or by 
clicking the icon you can define the calibration chart for the 
measurement by entering information on the measurements in 
the calibration window. By clicking yes or no you can specify 
whether the chart window will open automatically after each 
measurement. 
 

 
 
If you enter the chart data only for measurement 1, they will 
automatically apply also to the other measurements. The charts 
can also be saved or edited later in the course of evaluation. 
ACCOM saves these data together with the measured data and 
prints them through the menu items Evaluate > Measured data, 
Evaluate > Characteristic data and Graphic > Print. 

ACCOM 73 



Measuring Procedure for KGF 

10a. Enter path 
 With the menu item Measure > Enter path you open the 
dialog box for describing a free-form path. Before ACCOM can 
start a measurement, you must either enter, open, or import a 
path. 
 

 
 
• Path description: Here you can enter a name for the free-
form path. 
 
• Arrow keys: Here you can change the sequence of the path 
elements. 
 

Note 
A feed rate has to be programmed before the first line or circle 
element. 
The starting point may only used at the beginning of the path 
sequence. 
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• Insert: By clicking this button you open the dialog box with 
which you can generate contour elements. 
 

 
 
 After you have entered all contour elements, close the 
“inserting a path” dialog box with Cancel. 
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• Straight line: Here you can enter the coordinates of the end 
point of a straight line segment.  
Input range:  -10 000 to +10 000 mm 
   -390 to +390 inches 
Click the button to call the following dialog box. 
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• Circle: After clicking the button, the following dialog box 
appears in which you enter coordinates of the end point of 
the circular path. 
Input range:  -10 000 to +10 000 mm 
   -390 to +390 mm 
You also enter the radius of the arc. 
Input range:  -10 000 to +10 000 mm 
   -390 to +390 mm 
Enter also the direction of rotation of the circular movement. 
The machine tool then moves on an arc from the end point of 
the last contour segment to the new end point. 
 

 
 

 

 
The radius must be large enough to enable the arc to 
extend from the end point of the last contour element to 
the end point of the arc. 
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• Feed rate: Enter the feed rate in the first line. After clicking 
the button, the dialog box appears in which you enter the 
nominal feed rate for the subsequent contour elements. 
Input range:  0.001 to 100 000 mm/min 
   0.000 04 to 3900 inches/min 
 

 
 
• Dwell time: Here you specify how long the machine is to wait 
at the current position until it begins the next movement. 
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• Starting point: In the next line you can enter a starting point if 
it differs from the datum specified under “Set datum.” After 
clicking the button, the following dialog box appears in which 
you enter coordinates of the starting point. 
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• Reversal point: In the next line you can enter a reversal 
point. A reversal point marks the end point of the last path 
element (line or circle) as a reversal point. Measurement data 
points after a reversal point are shown in a second color. Using 
more than one reversal point toggles the display color of the 
measurement. In that way some forward and backward 
movements can be displayed separately in 2 colors. 
 
 

 
 
 
 

Note 
The free-form contour does not have to end at its starting point. 
The starting and end points can be specified as desired. 
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• Edit: To edit a contour element, use the cursor to select the 
desired line in the sequence and click the Edit button. In this 
example, the last contour element is to be edited and therefore 
has a dark background. 
 

 
 
• Delete: To delete a contour element, use the cursor to select 
the desired line in the sequence and click the Delete button. In 
this example, the last contour element is to be deleted and 
therefore has a dark background. 
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• Save path: This button calls the following dialog box with 
which you can save the entered contour. 
 

 
 
• Load path: This button calls the following dialog box with 
which you can find a contour and open it. 
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• Import path: This button opens a dialog box in which you can 
load a contour in the form of a HEIDENHAIN NC program from 
file or transfer it from a HEIDENHAIN control via network 
connection. 
 

 
 
 When you have completed all entries to describe a contour, 
close the dialog box with OK. The contour that you have 
programmed appears on the screen. 
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10b. Entering a path according to ISO 10791-6 (K2) Feeds 
 With the menu item Measure  > Enter path according to  ISO 
10791-6 (K2) Feeds  you open the dialog box for creating a 
free-form path according to ISO 10791-6 (K2). 
 

 
 
• Path description: Here you can enter a name for the free-
form path according to ISO 10791-6-K2. 
• Feed rate: Enter here the maximum feed rate and rapid 
traverse speed for the machine to be tested. 
• Start position: Here you enter the start position of the 
measurement axis. 
• End position: Here you enter the end position of the 
measurement axis. The measuring lengths may vary for the 
different feed rates. 
• Maximum feed rate  = rapid traverse: If on the machine to 
be tested the rapid traverse speed corresponds to the maximum 
feed rate, select this check box. As a result, only three different 
feed rates will be tested. 
• Measuring plane: Here you select the measuring plane. 
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• Measurement axis: Select here the axis of measurement. 
• Start position X/Y/Z axis: Here you enter the start position of 
the second axis in the measuring plane. 
• Dwell time: Here you specify how long the machine is to wait 
at the end of a straight line until it begins the next straight line 
(recommended: minimum of 1s). 
• Generate path: Click this button to generate and display the 
path according to the specified options. 
• Save path: Click this button to save the entered ISO 10791-6 
(K2) path. 
• Open path: Click this button to select and open an ISO 
10791-6 (K2) path. 
 
 

10c. Entering a path according to ISO 10791-6 (K3) Interpolation 
 With the menu item Measure  > Enter path according to ISO 
10791-6 (K3) Interpolation you open the dialog box for creating 
a free-form path according to ISO 10791-6 (K3). 
 

 
 
• Path description: Here you can enter a name for the free-
form path. 
• Feed rate: The default feed rate of 250 mm/min is entered 
automatically for this test. 
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• Start position: Here you enter the start position for the test. 
• Measuring length: Here you enter the measuring length for 
the test. 
• Dwell time: Here you specify how long the machine is to wait 
at the end of a straight line until it begins the next straight line 
(recommended: minimum of 1s). 
• Working stroke: Enter the working stroke in dependency to 
the path length (1-10%). 
• Measuring plane: Here you select the measuring plane. 
• Measuring choice: Here you can select the oblique straight 
lines to be traversed for the ISO 10791-6 (K3) test. 
• Generate path: Click this button to generate and display the 
path according to the specified options. 
• Save path: Click this button to save the entered ISO 10791-6 
(K3) path. 
• Open path: Click this button to select and open an ISO 
10791-6 (K3) path. 
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11. Generating and transferring an NC program 
 If you wish to generate and transfer an NC program, call the 
menu item File > Upload NC program to TNC, and select the 
form in which you would like to transfer the NC program. 
 

 
 
• Generate according to options: This button calls a dialog 
box entitled Generate NC program for measurement in which 
you define the parameters for the NC program. 
• Load from file (TCP/IP): In the TCP/IP operating mode, a 
finished NC program is transferred from the file system of your 
PC to the NC control by a network connection. 
 
 

Note 
Alternatively you can use the HEIDENHAIN PC-Tool TNCRemo 
for the data transfer to the control. 
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• Mode: Choose the format of the NC program. 
• Program name: In TCP/IP mode you add the extension .H for 
HEIDENHAIN format or .I for ISO format to the NC program. 
• Measuring plane: Click the working plane of the machine tool. 
• Description of path—Select/enter: Here you select the 
program of the contour that is to be recorded with the KGM. 
You can also enter the measuring program here (see section 10, 
“Enter a Path”). 
• Save: Click to save the NC program. 
• Cancel: Click to close the dialog box. 
• Upload: Click to start the upload. 
 
Now an NC program is generated for the free-form contour and 
transferred to the root directory of the TNC in the default setting. 
Data transfer via TCP/IP opens a new file dialog window, where 
you can select the target directory on the control. 
 

 

 
The TNC does not answer if the network is not 
connected. 
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12. Start measurement 
 With the menu item Measure > Start measurement or by 
clicking the associated button you can now begin the 
measurement. 
 

 
 
• Measurement 1 – 4: Here you can specify the number under 
which your measurement will appear in the graphic. 
• Scaling of the graphic: Either you can preset the scaling as 
a fixed square with the diagonal corner points P1 (below left) 
and P2 (above right), or you can have the system generate it 
automatically. 
Input range P1, P2: -10 000 to +10 000 mm 
   -390 to +390 inches 
• Description of path—Select/enter: Here you select the 
program of the contour that is to be recorded with the KGM. 
You can also enter the measuring program here (see section 10, 
“Enter a Path”). 
• Display path: You can display the programmed contour. 
• Measuring times: The nominal time is the calculated ideal 
time needed for a contour, i.e. without considering the approach 
and braking behavior of the machine tool. 
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The maximum dwell time is the time that a machine can 
remain still before ACCOM stops recording the measured data, 
normally 1 second. If this time is too short or too long, you can 
change it here. 
The actual time is the time actually required by the machine 
tool to machine the programmed contour. This time is needed 
by ACCOM to record the measured data. It can be measured 
through check, after which it is used automatically during the 
measurement. If there is no checking, the nominal time, which 
can also be changed manually is used for recording the 
measured data. 
• Check: After you click this button, ACCOM prompts you to 
start the measuring program on the machine. Ensure that the 
feed rate is correct. 
 

 
 
After the machine stops moving, a warning might appear that 
the nominal time has been exceeded (in practice, the machine 
might not reach the specified feed rate). 
 Click OK. 
Now the actual time is displayed and is available to the system 
for the following measurement. 
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 Start: After you click this button, ACCOM waits for the 
beginning of measurement. 
 
 Now start the NC program on the machine tool. In the status 
line, ACCOM shows the condition of measurement. You can 
terminate the measurement with Cancel. 
 

 
 

 

 
Before you start the measurement, the scanning head of 
the KGM must be at the starting point. Otherwise the 
actual path will not agree with the nominal path. 

 
Note 

You can measure any path of traverse on the machine tool, 
even if it is not identical with the path entered in ACCOM. Pay 
attention to the duration of measurement and the size of the 
starting window (indicates the path of traverse at which the 
recording begins). This capability can be useful when you must 
measure complicated movements that are too difficult to 
program in ACCOM. In this case the nominal contour does not 
agree with the actual contour. 
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Data storage 
After conclusion of measurement, the following dialog box 
appears for data storage. 
 

 
 
With Measure > Start measurement you can start further 
measurements. 
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13. Open measurement 
 Through File > Open measurement  or by clicking the 
associated button you can load the measured data for further 
evaluation and display. The following screen appears. 
 

 
 
Since up to four measurements can be shown simultaneously, 
this dialog box enables you to open the measurements in any 
sequence. 
This menu item also enables you to call other motion error 
traces to the screen for further evaluation.   
 

 

 
The results of measurement are loaded into the system 
with menu item Open measurement. This is a prerequisite 
for display. Through the menu item Evaluate > Graphic 
you can influence how and whether the motion error 
traces are displayed (see also section 15, “Graphic 
Display”). 
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14. Evaluate measured data 
 You can view the raw measurement data through the menu 
item Evaluate > Raw data or by clicking the associated symbol. 
ACCOM shows the coordinates of the measurement points. 
 

 
Note 

The ACCOM data is saved in an ASCII file. The raw data are 
saved line by line, separated by tabs. You can load or import 
this file for further processing in other programs like Matlab, 
Origin, Microsoft Excel or Open Office. 
 
To print the raw data, click the print symbol. 

 
If you click Cancel, the dialog box closes. 
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15. Characteristic data acc. to ISO 10791-6 (K2, K3) 
 With the menu item  Evaluate > Raw data,  or by clicking the 
associated symbol, you can evaluate the characteristic data of 
the sequence of movements measured according to ISO 
10791-6 (K2, K3). 
 
• Evaluation according to ISO 10791-6 K2—Feeds 
 

 
 
• Evaluation according to ISO 10791-6 K3—Interpolation of 
two axes 
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16. Graphic display of free-form test results 
 You can specify the display mode of the motion error traces 
through the menu item  Evaluate > Graphic  or by clicking the 
associated symbol.  
 

 
 
• Release: Click the measurements to be displayed. 
• Representation—Normal: The nominal and actual paths are 
shown in the same scale. 
• Representation—Path zoom: The error along the contour is 
shown magnified in relation to the nominal path, whereby you 
can control the magnification factor. 
•Representation Feed rate/Path: The feed rate curve is 
zoomed in relation to the nominal path. The magnification can 
be chosen with the magnification factor. A factor of 0.001 
means the scaling of the feed rate is 1000 (mm/min)/div if the 
scaling of the nominal path is 1 mm/div. If the sampling rate is 
higher than 1 kHz the feed rate is filtered by a gliding average 
filter.  
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• Style—XY: The curve is shown in the measuring plane. You 
can vary the size ratio between the two coordinate axes with the 
X/Y factor. 
• Resolution: You can set a fixed resolution for the graphic. 

Note 
The XY scaling factor is useful for contours with large aspect 
ratios. 
 
• Style—Xt/Yt/Zt: This display style of the trace over the 
measuring time can be selected only with normal 
representation. 
With the time factor you can vary the display ratio of path to 
time axis (mm/div to 1s/div). 
 
• Style—Vt: Display of the feed rate curve in relation to the 
measurement time.  
 
• Size of the overview window: The scaling of the graphic is 
fixed as a square with the diagonal corner points P1 (below left) 
and P2 (above right).  
Input range P1, P2: -10 000 to +10 000 mm 
   -390 to +390 inches 
• Active nominal path: Here you select the measurement 
whose further data is to be shown in the legend. 
 
• Options in mode path zoom: Here you can choose the 
method used by ACCOM to calculate and display the magnified 
deviation to the nominal path. (-> Path zoom options) 
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Representation—Normal: 
The nominal path and actual path can be magnified, reduced, 
or shifted by an equal factor through the menu items Zoom and 
Move. 
 

 
 
Details can be magnified both in the right and left windows by 
clicking and pulling with the mouse. The example below shows 
the magnified point of the contour. 
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Representation—Path zoom: 
In this display mode, the error is shown magnified with respect 
to the contour elements. 
 
Vanishing point zoom at corners enabled: 
 

 
 
Vanishing point zoom at corners disabled: 
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Details of the contour can be magnified, reduced, or shifted 
through the menu items Zoom and Move.  
Details can be magnified both in the right and left windows by 
clicking and pulling with the mouse. 
 
You can load new measurements with File > Open 
measurement or by clicking on the associated button. 
 

 

 
An excessive number of contour elements can lead to 
calculational problems. 

 
 
Representation—Feed rate/path: 
The feed rate curve is zoomed in relation to the nominal path. 
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Style Xt / Yt / Zt: 
In this display mode the course of the path can be shown over 
time. This example shows a step-response test as is used to 
measure overshoot behavior in an axis, including the influences 
of static friction. It also serves to measure positioning accuracy. 
This test is made on machine tools for high-precision parts 
where increments of 0.01 to 0.1 µm are required. 
 

 
 
You can load new measurements with File > Open 
measurement or by clicking on the associated button. 
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Style Vt: 
In this display mode the course of the feed rate can be shown 
over time. This example shows a measurement acc. to 
ISO 10791-6 K2. 
 

 
 
Path zoom of a ISO 10791-6 K3 measurement 
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Path zoom options:  
Here you can choose the method used by ACCOM to calculate 
and display the magnified deviation to the nominal path. Option 
1, 2 and 7 directly affect the path zoom computation. The other 
options are display options only. 
 

 
 
1. Vanishing point zoom: The visualization of the magnified 
deviation of the actual data to the NC-path can be optimized 
around corners when choosing the vanishing point zoom.  
 
• Relative distance: Here you can choose the distance of the 
vanishing point from the corner relative to the shortest adjacent 
line. 
Input range:  0.01 to 0.25 
 
Without the vanishing point zoom option ACCOM calculates the 
magnified deviation identically for the complete path. This 
means the shortest distance from the measured data to the 
nominal path is calculated and displayed which is exactly the 
method used in all previous ACCOM versions.  
The next figure shows the path zoom functionality at a corner 
without the vanishing point zoom. A path zoom factor of 5 is 
used here. 
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Note  
Because the magnification is shown with respect to the contour 
elements, the discontinuous transitions between the elements 
are not defined. The deviation at corners is most likely 
calculated too small with this method. 
 
• Vanishing point zoom: Choosing the magnification of the 
deviation at corners towards a vanishing point on the bisecting 
line can optimize the display of the deviation to the nominal 
path geometry. The next figure shows in principle the 
calculation of the magnified measurement data. A path zoom 
factor of 5 is used here. 
 

  
 

Note  
The vanishing point zoom deforms continuously the magnified 
actual data from the perpendiculars to the NC-path to the 
corner. 
 

Note  
If the path zoom factor is too large or the distance of the 
vanishing point to the corner to small a part of the magnified 
measured data would be point reflected. 

  

 

 

Nominal path
Actual path (1xd)
Path zoom (5xd)
Magnification vector

 

 

Nominal path
Actual path (1xd)
Path zoom (5xd)
Magnification vector
Vanishing point
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2. Magnification at start/end of path: 
 Default behavior of the path zoom at start/end of the path: The 
actual data points (outside the nominal path) are magnified 
orthogonally to the extended nominal path (similar to older 
ACCOM versions).  
 

 
 
Alternatively you may use the evaluation of ACCOM 2.8-3.1. 
Here, the actual data points are magnified to the start/end point 
of the path (2D distance). 
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3. Corner gap:  
If you are not interested in the deviations at path transitions, 
you may leave a gap in the magnified data representation. 
 

 
Standard path zoom 
 

 
Option 3: Corner gap active (Example: 2 mm) 
 
• Length of the gap: Here you can set the length of the corner 
gap. 
Input range:  0.001 to 10.0 
 

Note  
Option 1 and 3 cannot be used at the same time. 
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4. Representation up to/above limit:  
a) Here you can set an upper limit up to the magnified 
measurement data is plotted. 
 

 
Option 4a: Representation up to a limit (here10 µm) 
 
b) Here you can set a lower limit from which the magnified 
measurement data is plotted. 
 
• Limit: Here you can set the limit value for the upper or lower 
limit. 
Input range: 0.0001 to 1.0 
 
 
5. Show nominal path:  
Here you can avoid the display of the nominal path. This option 
can be useful when comparing two measurements with different 
feed rates (slow/fast) in respect to the dynamic behavior of the 
machine. Global geometric errors to the nominal path are 
therefore suppressed (not visible) with this option. 
 
 
6. Show measurement:  
The default representation shows the complete measurement. If 
the nominal path has at least one reversal point, you can decide 
to show only the forward or backward part of the measurement. 
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7. Closed representation:  
The default representation shows the magnified deviation 
perpendicular to the nominal path. With option 7a the path 
zoom is shown in a closed representation. Here the 
magnification of the measurement data is not always shown 
perpendicular to the nominal path, especially around corners. 
As a mathematical intermediate step a best-fit optimization is 
computed (option 7b). Here a minimum deviation of the 
complete measurement is computed. 
 

Example 
The following simple nominal path (square) demonstrates the 
use of the option „Closed representation.  
 

 
Standard path zoom 
 

 
Option 7a: Closed representation 
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Option 7b: Best-fit representation 
 

Note  
The closed representation is not suitable for all nominal and 
measurement data. Therefore it is not generally recommended 
as the standard representation in ACCOM. 
 
When using the closed representation with more than one 
measurement (different nominal paths or feed rates) the best-fit 
optimization of one measurement can be used for all 
measurements (7c and 7d).  The best-fit optimization should be 
computed with a reference measurement at a low feed rate. 
Using this option offers a better look at dynamic effects with the 
same nominal path. A second measurement with higher feed 
rate uses the best-fit optimization of the reference measurement 
(7c). To avoid global geometric deviations in the representation 
of dynamic deviations you may use option 7d. Again, a slow 
reference measurement and a fast measurement are 
necessary. 
 

Example 
The following free-form path demonstrates the use of the 
„Closed representation with reference measurement“. The next 
three graphics show a reference measurement (red/pink, F=200 
mm/min) and a dynamic measurement (blue/light blue), F = 
15000 mm/min) with a forward (red and blue) and backward 
part (pink and light blue). 
In addition option 3 is used here (corner gap) to avoid the 
visualization of the path deviations at the transitions. 
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Standard path zoom 
 

 
Option 7c: Closed representation with reference measurement 
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Option 7d: Best-fit representation with reference measurement 
 

Note 
Using options 7a-d (closed and best-fit representation):  
The deformation of the magnified contour deviation could lead 
to a misinterpretation of the actual deviation. Especially with 
option 7b and 7d the global geometric error of the measurement 
is removed. The closed representation is primarily a display 
tool. Simple and ideal contours (e.g. square or cross) show 
nearly the same deviations with option 7a and the default path 
zoom display. Large deviations in the measurement data could 
lead to a deformation of the magnified path zoom after the best-
fit algorithm.  
 
 

Note 
The used options are shown in the graphics display. 
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Evaluation of contour deviation and path time 
The area between the measurement data and the nominal path 
could be used as a more objective value for various 
measurements (mean deviation). The calculation of the 
effective deviation will additionally reduce noise effects. 
A machine tool is normally not fully compensated at the time of 
the measurement. Missing linear or nonlinear axis 
compensations, kinematic errors or missing thermal 
compensations affect the calculation of the maximum, mean 
and effective deviation. A more objective calculation can be 
achieved by using an additional reference measurement to 
reduce global deviations of the measurements to the nominal 
path (2 offsets, 2 axis scalings, 1 squareness and 1 rotation). 
This procedure is especially beneficial by using a low feed rate 
measurement as a reference measurement before a dynamic 
high speed measurement. 
 
 

 
 
 
Maximum deviation:  
Maximum contour deviation of all measurement points 
 
Path time:  
Looking at the measurement data until standstill is used as path 
time (the standstill window is used as a threshold) 
 
Mean deviation:  
Mean contour deviation of all measurement points (Absolute 
values) 
dev_m = sum(da*dl)/l 
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Effective deviation:  
Effective contour deviation of all measurement points (RMS 
value) 
dev_eff = sqrt(sum(da*da*dl)/l) 
 
da: Mean deviation of 2 neighboring data points (Absolute 
value) 
dl: Distance between the 2 neighboring data points (at the base 
points) 
l: Total length (Sum of all used elements dl) 
 

Note  
The used method for the path-zoom calculation is documented 
in the lower status window. 
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Current evaluation 
The maximum deviation of the current detail in the display mode 
path-zoom is shown here. The sign of the deviation value is 
determined by the movement: Deviations on the right side of the 
moving direction are shown with a positive sign. 
 

 
 
The minimum and maximum value of the specified axis is 
shown in the display mode Xt (Yt / Zt). 
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Color settings of the graphic 
If you would like to change the color setting of the graphics, 
you can change the color of the error traces, of the coordinate 
system and the graphic background with the menu item  
Options > Color setting. 
The 2 colors of each measurement are used  

Saving/loading the options 
You can save these settings with the menu item  Options > 
Save options. 
You can call these settings with the menu item  Options > Load 
options. 
 

Exporting the measurement graphic 
If you wish to export the measured graphic as a file without a 
log, you can save it as a bitmap using the menu item Graphic > 
Save. 
 

Printing the graphic 
You can print the graphic with the menu item Graphic > Print. 
You can change the printer settings through the menu item 
File > Printer setup. 
 

Saving a measurement 
If you make changes to a calibration chart, you can save 
them through the menu item  File > Save measurement  or by 
clicking the save button. 
As an alternative, you can also save the measured data through 
the menu item  File > Save all measurements. 
 

Clearing the screen 
To remove the motion error traces from the screen, you can 
clear the screen with the menu item  Graphic > Close. 
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Editing the calibration charts 
If you would like to edit the calibration charts you can select 
the desired chart through the menu item Measure > Calibration 
chart or by clicking the associated symbol. 
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Measuring Procedure for VM Linear Test (VML) 

Machine cleaning 
 Before beginning to mount the VM, clean the area of the 
machine tool in which the measurements are made. Pay special 
attention to any chips and oil or grease residue that could fall 
onto the encoder. 
 

 

 
Give the encoder time to adjust to the ambient 
temperature before you begin mounting it. This will help 
to prevent thermally induced error. 

 
Test program 

For non-HEIDENHAIN controls, a typical test program for 
comparative linear measurements with reverse cycle could be 
written as follows, whereby movement must be measured 
parallel to the measuring axis. With HEIDENHAIN controls, the 
machine program can be transferred directly from ACCOM.  
 
Part 1, forward cycle: The measuring head starts at a reversal 
point. Forward movement to the datum, dwell time and 
automatic recording of the measuring point. Forward movement 
to the next position, dwell time and automatic recording of the 
measuring point, ... , last position, dwell time and automatic 
recording of the measuring point. 
Part 2, reverse cycle: Movement by the reversal path forward, 
dwell time, backward movement to the last position, dwell time 
and automatic recording of the measuring point, backward 
movement to the point before last, dwell time and automatic 
recording of the measuring point, ..., datum, dwell time and 
automatic recording of the measuring point. 
Possible further cycles: Like the 1st forward cycle, this cycle 
would also begin with a backward movement by the reversal 
path.  
 

 

 
Ensure that there are no “forgotten” compensation data 
saved in the control that could cause a movement 
perpendicular to the encoder or corrupt the measurement. 
The measuring head must maintain a constant angular 
position. You might try running the machine program 
without the encoder. 
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Measuring assembly 
 Ensure that the IK 220 PC counter card was installed in your 
PC according to the instructions in the User’s Manual. 
Alternatively you can use the EIB 741. Please ensure an 
available peer-to-peer network connection to the EIB 741 
(address and subnet mask of the TCP/IP connection). Connect 
the encoder cables to X11 and X12. 
Now mount the VM or KGM according to the instructions in the 
manual. When mounting the KGM, do not use any screws 
whose heads project above the height of the cross grid! Use a 
dial gauge to align the VM parallel to the axis by approx. 10 µm. 
 

 

 
When connecting the measuring cables, be sure to leave 
enough slack to compensate any machine movement 
during measurement. 

 
 Before starting ACCOM, connect the enclosed hardware key 
with ld. No. 590255-01 or 590255-02 to one free USB port. 
 
After calling ACCOM, proceed as follows: 
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1. Select measuring method 
After ACCOM is started, a dialog box appears in which you can 
select the type of measurement. 
 
 Click the VM linear test button to start the corresponding 
program part. 
 
With the menu item File > Select measuring method or by 
clicking the icon you can select the individual measuring 
methods from within the running program. 
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2. Specifying the unit of measure 
 With the menu item  Options > Unit of measurement  you 
specify the desired unit of measure. Close the dialog box with 
OK. 
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3. Settings of the encoder and the counter card 
 Under  Option > Measuring interface  you set the parameters 
for the encoder used. 
• Signal period: Here you set the signal period (as its distance 
in µm) of the encoder you are using. The default setting for the 
signal period is 4 µm. 
Input range:  0.1 to 20 µm 
• Signal source: Select the model of encoder being used. 
• Count direction 2nd axis to 1st axis (VM 182 only): 
According to the set-up of the VM 182 it can be necessary to 
manually set the count direction for the 2nd axis (orthogonal 
axis). 
 

 
 
 Under  Option > Counter card  you set the parameters for the 
counter card. 
• Type counter card: Here you select the model of counter 
card that you are using. 
• Signal input: Here you select the type of measuring signal. 
• Address EIB 741: Here you enter the IP address of the EIB 
741 (see also EIB 741 user manual). Alternatively you may use 
the DHCP hostname in a company network. However it is not 
recommended due to the high data acquisition rate. 
This setting is not needed for the IK 220. 
• Automatic connection at program start: ACCOM connect 
to the EIB 741 at the next program start automatically if chosen. 
A valid connection to the EIB 741 is required! 
• Test IK (IK 220): Here you can then test the counter card for 
proper function.  
• Connect/Disconnect (EIB 741 only): The EIB 741 will be 
connected or disconnected here. 
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Ensure that you have entered the proper model, address 
and signal input of the counter card. If the signal period is 
entered incorrectly, the distances will be measured too 
large or too small. 

 
Note 

Only EIB 741: Connect the KGM/VM to the encoder inputs X11 
and X12. 
 

 

 
If you have problems receiving data from the counter 
card, use the test programs on the provided driver CD to 
check whether the card can be used. 
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4. Fine adjustment of the measuring head 
 

Oscilloscope 
 With the menu item Equipment > Oscilloscope you can 
display the measuring signals received by the PC counter card 
as Lissajous figures. You need this for the fine adjustment of 
the encoder (see mounting instructions of the KGM or VM). 
 

 
 
The measuring signals are displayed for the directions I and II in 
the oscilloscope display mode (for measuring signals 0° elec. 
and 90° elec.). 
 
 When using the KGM, move the machine tool slide slowly 
and evenly in diagonal direction. Use the adjusting screws on 
the measuring head to adjust the signal amplitude. In the ideal 
case, the measuring signal amplitude lies near the green 
circular path (1 VPP) between the red limit circles. 
 
If the encoder signal is too large or small, the message 
Amplitude too high / too low appears in the status line of the 
ACCOM screen. 
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Optimizing the measuring signals 
 Through automatic signal adjustment, ACCOM can optimize 
the measuring signals to attain very high accuracy. Click the 
boxes Compensation X1 (X11) and Compensation X2 (X12) 
and, when using the KGM, move the machine slides slowly 
and evenly in diagonal direction. When using the VM, move 
only in paraxial direction. Then switch this function off by 
clicking both boxes Compensation X1 (X11) and Compensation 
X2 (X12) again, and go to the next item of the instructions. The 
EIB 741 optimizes the analogue signals automatically. 
However, the optimized analogue signals are used only for the 
computation of the position values. Therefore it is possible to 
observe imperfect circular Lissajous figures. 
 

 

 
If the displayed signal amplitude is too low, check 
whether the settings for the interface are correct and 
whether the encoder is correctly installed. Then start 
ACCOM again. Do not engage or disengage any 
connectors until you have exited ACCOM! 

 
 

Position display 
With the menu item Equipment > Position display you can call 
the position display for the connected encoder and, for 
example, check the positive counting direction of the KGM/VM. 
If you call this function after setting the position (see section 8, 
“Set datum”), before the test you should check again whether 
your datum is set correctly and, if not, enter it again. 
 

 
 
 

  

124 HEIDENHAIN 



 Measuring Procedure for VML 

5. Parameters of the measurement 
 By calling the menu item Options > Parameters of the 
measurement or clicking the icon, you open the following dialog 
box in which you can adjust the parameters of the 
measurement. 
 

 
 
• Axis: Select here the axis of measurement. 
• Orthogonal axis: The orthogonal axis can be selected here 
when using the KGM or the VM 182. 
 
• Amount of pos.: The number of positions is defined 
automatically when the nominal positions are specified. 
• Nominal positions: You have a choice among four 
possibilities: 1st/2nd point 
  1st/last point 
  1st point/step width 
  All points 

1st/2nd point: Here you enter the first and second 
measuring points as well as the total number of measuring 
points (including the first and last). ACCOM automatically 
calculates all measuring points and shows them in the 
position list. 
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1st/last point: Here you enter the first and last measuring 
points as well as the total number of measuring points 
(including the first and last). ACCOM automatically 
calculates all measuring points and shows them in the 
position list. 
1st point/step width: Here you enter the first measuring 
points and the step width between the measurement points 
as well as the total number of measuring points (including 
the first and last). ACCOM automatically calculates all 
measuring points and shows them in the position list. 
All points: Here you can enter all positions, which are then 
shown in the position list. The positions must be entered 
in ascending order. 
 

 
Note 

The nominal positions have to be in monotonically increasing 
order. 
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Note 
With Save you can save the file under any name and edit it later 
with the editor or a spreadsheet program such as Microsoft 
Excel or Open Office. In this way you can also generate random 
values. With Load you can read existing files into the measuring 
program. 
 
• Trigger mode—Manual: In this setting you must use the 
Save key in the measuring dialog box to manually confirm that 
the measuring position has been reached. 
• Trigger mode—Automatic: 
 Position window: Enter here the size of the positioning 

window (nominal position ± position range) within which a 
momentary position is considered to have been reached. If 
the range is too small, a measuring cycle will be interrupted 
by large error values. If it is too large, the measured value 
will be Saved too soon. 

 Standstill speed: For automatic position detection, the 
change in position must be smaller than the standstill 
speed specified here. 

• Cycles: Here you enter how many times in a row the nominal 
positions are to be scanned. You must previously have clicked 
Backward cycles (positions are also approached backward), 
otherwise only one forward cycle is possible. 
• Reversal dist.: The distance to be traversed so that the same 
nominal position can be approached from the opposite 
direction. ACCOM recognizes the backward movement after 
half the distance. For extremely high traversing speeds, enter a 
dwell time at the end of the reversal distance in the NC 
program. 
• Dwell time: Here you specify how long the machine is to wait 
at one position until it approaches the next position. ACCOM 
automatically records the measured values after half the dwell 
time. 
• Measuring mode—Linear: All positions are traversed in 
sequence. 
• Measuring mode—Step cycle: Each nominal position is 
approached in positive and negative direction as many times as 
is defined under Cycles. The process is repeated in sequence 
at all positions. 
• Backward cycles: Here you specify whether the nominal 
position will also be approached backwards. If the backward 
cycles are not checked, you can run only the linear measuring 
process with one forward cycle. 
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• Check position traverse: This option should be enabled for 
all ISO-230-2 measurements. ACCOM then always checks 
whether a measurement position has been skipped. If that 
happens the trigger conditions "position range" and "standstill 
range" should be increased. 
However this option has to be disabled for ISO 230-3 
measurements with additionally heating cycles in between the 
measurement cycles. Here the trigger conditions have to be 
increased as well. 
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6. Setting the NC interface 
 If you wish to transfer the measuring program in ACCOM to 
a HEIDENHAIN control, select  Options > NC programming  to 
open a dialog box in which you can configure the network 
connection. 
 

 
 
• Mode: Choose between HEIDENHAIN or ISO format. 
• Feed rate: Here you enter the nominal feed rate for the 
circular motion. 
Input range:  0.001 to 100 000 mm/min or 
   0.000 04 to 3900 inches/min 
• Program name: Here you give the program a name (the 
extension .H stands for HEIDENHAIN, .I stands for 
HEIDENHAIN ISO and .txt for general ISO). 
• Decimal place: Select the decimal place of the NC programs. 
• M functions: Here you enter additional M functions which are 
necessary to run the NC program on the control. 
The M functions are added to the first NC block. 
Example in HEIDENHAIN conversational programming:  
2 L X0 F1000 M31 
• TCP/IP address: Here you enter the TCP/IP address or 
DHCP hostname of the control for the data transfer via network 
connection. 
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G-Code options 

 
 By clicking the control button Options the following dialog 
box opens. Here you can configure some ISO format settings 
which are suitable to the control.  
 

 
 
• Position (export only): This parameter is used in the export 
of an ISO NC program only. For absolute positions G90 is 
added at the NC program start, for incremental positions G91 is 
used.  
For absolute NC programs it is useful to add a datum shift (e.g. 
G54). 
• Circle center: The input of the circle center point acc. to the 
German standard DIN 66025 is done incremental to the last 
position or absolute. Usually I, J, K are used with incremental 
positions. Valid is also an absolute position with I, J, K. 
(depends on the control). 
• Feed rate: This parameter is only valid for an INCH program. 
The feed rate can be set in Inch/Min or Inch/10Min 
(HEIDENHAIN default). 
• G-code for Inch/MM: You can choose whether to use 
G71/G70 for NC programs or not. 
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In the dialog box Parameters for NC-programming you may 
add the following data for the ISO format programming: 
• Additional lines at program start: Here you can add 2 user 
or control specific lines at program start (e.g. G54). 
• Additional lines at program end: Here you can add 2 user 
or control specific lines at program end (e.g. M30). 
 
 

Network cable 
 
Connect the TNC by a (crossed) network cable directly to the 
PC or by using a standard network cable with a hub or a switch 
to the company network. 

Note 
Peer-to-peer (direct connection): You need to set the IP-
Address of the PC in Control Panel / Network / TCP-IP / 
Properties (depends on the operating system). As default the 
value for the IP-Address will be given automatically in a 
company network (from the DHCP Server). 
 
 
LAN (Network) with a 1:1 cable 

 
 
 
Peer-to-peer (direct connection) with a (crossed) cable! 
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7. Setting the direction 
 KGM: Before the first measurement with the KGM, ACCOM 
must know the positive counting direction of each axis as well 
as the angular position of the KGM on the machine table. In the 
menu item  Measure > Directions, ACCOM prompts you to 
move the machine slides in sequence in the direction shown in 
the dialog box. The directions depend on the setting of the 
measuring plane (see positive direction I and II on the KGM). 
To optimize the angle compensation, enter if possible your 
entire traverse distance in the dialog box. The required 
accuracy data is calculated from the signals of the encoder 
(channel assignment, counting direction and angular position). 
 VM: Before the first measurement with the VM, ACCOM 
needs to know the positive counting direction. In the menu item 
Measure > Directions, ACCOM prompts you to move the 
machine slides in sequence in the direction shown in the dialog 
box. The directions depend on the setting of the measuring 
axes. The positive counting direction of the orthogonal axis can 
be recognized with the “right-hand rule.” The VM has no 
automatic angular error compensation. It is therefore important 
that the encoder is aligned exactly.  
 

 
 

 

 
During the directional detection, do not move the 
machine tool slide in a diagonal direction. Otherwise the 
detected angular position will be incorrect. Movement in 
diagonal direction will result in damage to the VM! 
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8. Set datum 
 In the menu item Measure > Set datum you assign ACCOM 
a position value in agreement with the control. 
Example: 
If the scanning head is located at the starting position, you 
assign it the coordinates X0 and Y0. 
 

 
 

 

 
When using “Set datum” and “Set direction” do not forget 
the influence on the measurement of the backlash in NC 
axes, especially at the beginning of the measurement. 

 
 

Last initialization 
After you have started ACCOM you can use your previous 
settings by calling the menu item  Measure > Last initialization, 
provided that the setup of the VM 182 on your machine has not 
changed and you move the scanning head to the position last 
set. Then continue with the next program item. 
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9. Generating and transferring an NC program 
 If you wish to generate and transfer an NC program, call the 
menu item File > Upload NC program to TNC, and select the 
form in which you would like to transfer the NC program. 
 

 
 
• Generate according to options: This button calls a dialog 
box entitled Generate NC program for measurement in which 
you define the parameters for the NC program. 
• Load from file (TCP/IP): In the TCP/IP operating mode, a 
finished NC program is transferred from the file system of your 
PC to the NC control by a network connection. 
 

Note 
Alternatively you can use the HEIDENHAIN PC-Tool TNCRemo 
for the data transfer to the control. 
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• Mode: Choose the format of the NC program. 
• Feed rate: Enter here the nominal feed rate of motion. 
Input range:  0.001 to 100 000 mm/min 
   0.000 39 to 3937 inches/min 
• Program name: In TCP/IP mode you add the extension .H for 
HEIDENHAIN format or .I for ISO format to the NC program, 
Ext/ME mode there is no extension. 
• Axis: Select here the machine axis being used. 
• Save: Click to save the NC program. 
• Cancel: Click to close the dialog box. 
• Upload: Click to start the upload. 
 
Now an NC program is generated for the VM linear 
measurement and transferred to the root directory of the TNC in 
default setting. Data transfer via TCP/IP opens a new file dialog 
window, where you can select the target directory on the 
control. 
  

 

 
The following prerequisites must be met for the correct 
execution of the NC program.  
1. At program start, the scanning head must be located at 
the starting point. 
2. The correct program is selected at the control. 

 
 

 
The TNC does not answer if the network is not 
connected. 
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10. Generating a calibration chart 
 Through the menu item Measure > Calibration chart or by 
clicking the icon you can define the calibration chart for the 
measurement by entering information on the measurements in 
the calibration window. By clicking yes or no you can specify 
whether the chart window will open automatically after each 
measurement. 
 

 
 
If you enter the chart data only for measurement 1, they will 
automatically apply also to the other measurements. The charts 
can also be saved or edited later in the course of evaluation. 
ACCOM saves these data together with the measured data and 
prints them through the menu items Evaluate > Measured data, 
Evaluate > Characteristic data and Graphic > Print. 
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11. Start measurement 
 Select the menu item Measure > Start measurement or click 
the associated button to open a dialog box with which you can 
start the measurement after entering the following parameters. 
 

 
 
• Measurement 1-4: Click the number under which the 
measurement is to be shown later. 
• Scaling Dmax/Dmin: Enter here the upper and lower limit of 
the expected error. You can change the scaling at any time 
later during the evaluation. 
• Display orthogonal axis: Here you can deactivate the 
display of the orthogonal axis when you are using the KGM or 
VM 182. The measured values of the orthogonal axis are 
nevertheless recorded. 
• Scaling of the orthogonal axis Dmax/Dmin: If you are using 
the KGM or VM 182, enter here the upper and lower limit of the 
expected error in orthogonal direction. You can change the 
scaling at any time later during the evaluation. 
 

 

 

The following conditions must be fulfilled for a correct 
measurement: 
1. The measurement parameters entered in ACCOM 
must correspond to reality. 
2. The scanning head must be at the starting position. 
3. The correct NC program must be selected. 
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 Start: After you click this button, ACCOM waits for the 
beginning of measurement. Start the measuring program on the 
machine tool. The progress of measurement is shown on the 
screen. You can terminate the measurement with Cancel. The 
measured cycles can be saved through the menu item File > 
Save measurement or evaluated with the menu items Evaluate 
> Raw data, Characteristic data and Graphic. 
 

 
 

 

 
When using the NC program generated by ACCOM, at 
the beginning of measurement the scanning head should 
be at the reversal position. Recording begins after the 
subsequent forward motion to the starting point. 

 
Note 

While the VM measurement is running, the measurement data 
is saved in a temporary file. After a PC or program crash the 
temporarily saved data can be recovered in the menu item File 
> Open measurement. 
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Data storage 
After conclusion of measurement, the following dialog box 
appears for data storage. 
 

 
 
With Measure > Start measurement you can start further 
measurements. 
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Entering temperature values 
If you wish to save the ambient temperature values and other 
temperature values, the ISO 230-3 standard must be selected 
under the menu item Evaluate > Standard.  Then select the 
menu item Evaluate > Temperature table to open a dialog box 
in which you can enter the temperature for each cycle. 

Note 
It suffices to enter at least two temperature values. The 
temperature curve between them is interpolated linearly.  
 
Then save the file through the menu item File > Save 
measurement.  
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12. Open measurement 
 Through File > Open measurement  or by clicking the 
associated button you can load the measured data for further 
evaluation and display. The following screen appears. 
 

 
 
This dialog window enables you to open the measurements in 
any sequence. 
This menu item also enables you to call other motion error 
traces to the screen for further evaluation.   
 

 

 
The results of measurement are loaded into the system 
with menu item Open measurement. This is a prerequisite 
for display. Through the menu item Evaluate > Graphic you 
can influence how and whether the motion error traces 
are displayed (see also section 16, “Graphic Display”). 
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13. Evaluate measured data 
 You can view the raw measurement data through the menu 
item Evaluate > Raw data or by clicking the associated symbol. 
ACCOM shows every measured deviation including the 
associated coordinates. 
 

 
 
Note 

The ACCOM data is saved in an ASCII file. The raw data are 
saved line by line, separated by tabs. You can load or import 
this file for further processing in other programs like Matlab, 
Origin, Microsoft Excel or Open Office. 
 
To print the raw data, click the print symbol. 

 
If you click Cancel, the dialog box closes. 
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14. Select standard for evaluation 
 In the menu item  Evaluate > Standard  you can select the 
guideline for further evaluation. 
ISO 230-2 
VDI/DGQ 3441 
ISO 230-3 
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15. Characteristic values 
 With the menu item Evaluate > Characteristic data, or by 
clicking the associated symbol, you can display the results 
calculated from the measured data according to ISO 230-2 or 
VDI/DGQ 3441.  
 
To print the accuracy data, click the print symbol in the menu 
bar. 
 
You can save the characteristic values in an ASCII file (*.csv). 
 
If you click Cancel, the dialog box closes. 
 
• Example of accuracy data as per ISO 230-2: 
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• Example of accuracy data as per VDI/DGQ 3441: 
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• Save characteristic data 
 

 
 
• Output: Here you can select the measurement axes for the 
data output. 
• Data output: Here you can select the kind of data which will 
be saved in the CSV-file. 
• Data separator: Here you can select the data separator used 
in the CSV-file. 
 • Decimal point: Here you can select the decimal point used 
in the CSV-file. 
• Save: Here you can save the characteristic data. A file dialog 
window opens and the data is then saved in an ASCII file 
(*.csv). 
 
Example: 
Settings: Meas. axis only, Characteristic data of the 
measurement only, Data separator: tabulator, decimal point: 
comma  
Output of the ISO 230-2 characteristic data in 2 lines 
 

B [µm] Bm [µm] A [µm] A+ [µm] A- [µm] R [µm] 
1,12 -0,28 10,41 10,37 10,16 5,12 

 
R+ [µm] R- [µm] E [µm] E+ [µm] E- [µm] M [µm] 

4,40 5,12 8,23 7,98 8,17 8,04 
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16. Graphic display of measurement results 
 You can specify the display mode of the motion error traces 
in accordance with the selected standard through the menu 
item Evaluate > Graphic or by clicking the associated symbol.  
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• Release: Select the measurement to be displayed. 
• Scaling of measured axis deviation: 
 Fixed: Enter the upper and lower limit of the error display. 
 Automatic: The scale is determined automatically. 
• Scaling of orthogonal axis deviation: 
 Fixed: Enter the upper and lower limit of the error display. 
 Automatic: The scale is determined automatically. 
 Linear correction: If you activate this check box, a linear 

regression over the error curve is calculated and the 
calculated linear error is subtracted from the measured 
error and displayed. This is useful whenever the VM 182 
cannot be set up parallel to the measuring direction. 

• Scaling of measurement length (abscissa): 
 Fixed: Enter the upper and lower limit of the abscissa. 

 Automatic: The limits of the abscissa are determined 
automatically. 

• Display: 
 Measuring axis: Only the axis of traverse is displayed. 
 Orthogonal axis: Only the axis perpendicular to the axis of 

traverse is displayed. 
 Both axes: Both axes are displayed. 
• Representation: The available display modes depend on the 
selected evaluation standard. 
 ISO 230-2: Separate cycles 
   ISO 230-2 
   Averaged deviation 
   Backlash 
   Repeatability  
 VDI/DGQ 3441: Separate cycles 
   Characteristic values 
 ISO 230-3: Position drift as per cycles 
   Position drift as per time 
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• Separate cycles 
 

 
 
• Characteristic values 
Graphic as per VDI/DGQ 3441 
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• Graphic as per ISO 230-2 
 

 
 
• Averaged deviation 
Graphic as per ISO 230-2 
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• Backlash 
Graphic as per ISO 230-2 
 

 
 
• Repeatability  
Graphic as per ISO 230-2 
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• Position drift (cycles) 
Graphic as per ISO 230-3. 
Temperature input under Evaluate > Temperature table. 
 

 
 
• Position drift (time) 
Graphic as per ISO 230-3. 
Temperature input under Evaluate > Temperature table. 
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17. Run linear compensation on NC control 
ACCOM enables you to read the compensation positions 
defined in the TNC and output the correct compensation values 
after the measurement. 
 
Proceed as follows: 
 
 Before entering the measuring parameters, use the menu 
item File > Download TNC compensation to transfer the 
compensation position table in the TNC to ACCOM. 
Select between the standard format COM for current 
HEIDENHAIN controls. 
 

 
 
The following window with the PLC directory of the 
HEIDENHAIN control appears in TCP/IP mode. Before you can 
access the PLC directory it is necessary to enter the PLC code 
number. For this purpose a dialog box appears once. In the 
PLC directory you can choose explicitly the compensation value 
table which should be written into by ACCOM. 

Note 
To build a new table see technical manual of the TNC. 
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 Enter the measuring parameters through the menu item 
Options > Parameters of measurement. ACCOM automatically 
transfers the position values from the TNC compensation table. 
 

 
 
 Specify the NC interface. 
 
 Run the directional detection and set the position. 
 
 Generate the NC program and transfer it. 
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 Generate the calibration chart. 
 
 Run the measurement. The position error values are then 
used as compensation data. 
 
 After the measurement, use the menu item File > Show 
compensation values to call a list of compensation values. 
 

 
 
 If you click Save, you can later read the ASCII file with a text 
editor or e.g. Microsoft Excel or Open Office. 
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 Output the compensation value table through the menu item 
File > Upload TNC compensation. In the following dialog box 
you can select the compensation values. 
 

 
 
• Select compensation column:  Choose the column of the 

compensation table which you would like to correct. 
 
• Compensation values: 
 Mean value: The mean value of the position error of all 

forward and backward cycles will be used as compensation 
values. 

 Forward cycles: The position error of the forward cycles 
will be used as compensation values. 

 
• Use of the compensation values: 
 Absolute: Existing values in the chosen column will be 

overwritten. You should use this option if there was no non-
linear axis compensation active while measuring or the 
specified column was empty. 

 Incremental: This option allows adding a position error to 
existing compensation values in the specified column.  

 
• Use compensation values of the: 
 Measurement axis:: Compensation values of the position 

error will be inserted into the chosen column. 
 Orthogonal axis: Compensation values of the straightness 

error will be inserted into the chosen column. 
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• Compensation of the backward cycles:  
 TNC 640/TNC 620:: The position error of the backward 

cycles will be written in column BACKLASH in the same 
file. 

 iTNC 530: Choosing this option will generate a second 
compensation file with the position error of the backward 
cycles in the same column. This compensation table may 
be used by newer TNCs for the negative direction of 
traverse. 
Example: Name of the compensation table: x.com -> then 
the name of the file for the negative direction of traverse is: 
x-.com. 

 
After confirmation with Ok the next dialog box will be displayed 
where you can select the output. 
 
• Upload table by network (TCP/IP): Output by network 
connection in TCP/IP protocol. 
• Save: Output to the file system. 
 

 
 
The following window with the PLC directory of the 
HEIDENHAIN control appears in TCP/IP mode. Here you can 
choose the directory and filename of the compensation value 
table on the TNC. 
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After you have installed the compensation values, be sure 
to run an inspection measurement. 
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Color settings of the graphic 
If you would like to change the color setting of the graphics, 
you can change the color of the error traces, of the coordinate 
system and the graphic background with the menu item  
Options > Color setting. 
 

Saving/loading the options 
You can save these settings with the menu item  Options > 
Save options. 
You can call these settings with the menu item  Options > Load 
options. 
 

Exporting the measurement graphic 
If you wish to export the measured graphic as a file without a 
log, you can save it as a bitmap using the menu item Graphic > 
Save. 
 

Printing the graphic 
You can print the graphic with the menu item Graphic > Print. 
You can change the printer settings through the menu item 
File > Printer setup. 
 

Saving a measurement 
If you make changes to a calibration chart, you can save 
them through the menu item  File > Save measurement  or by 
clicking the save button. 
As an alternative, you can also save the measured data through 
the menu item  File > Save all measurements. 
 

Clearing the screen 
To remove the motion error traces from the screen, you can 
clear the screen with the menu item  Graphic > Close. 
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Editing the calibration charts 
If you would like to edit the calibration charts you can select 
the desired chart through the menu item Measure > Calibration 
chart or by clicking the associated symbol. 
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Measuring Procedure for Rotatory test (VMR) 
Machine cleaning 

 Before mounting the encoder, clean the area of the machine 
tool in which the measurements are made. Pay special attention 
to any chips and oil or grease residue that could fall onto the 
encoder. 
 

 

 

Give the encoder time to adjust to the ambient 
temperature before you begin mounting it. This will help 
to prevent thermally induced error. 

Test program 
For non-HEIDENHAIN controls, a typical test program for rotary 
table inspection with backward cycle could be written as follows. 
With HEIDENHAIN controls, the machine program can be 
uploaded directly from ACCOM.  
 
Part 1, forward cycle: The angle encoder starts at the reversal 
point. Forward movement to the datum, dwell time and 
automatic recording of the measuring point. Forward movement 
to the next position, dwell time and automatic recording of the 
measuring point, ... , last position, dwell time and automatic 
recording of the measuring point. 
Part 2, reverse cycle: Movement by the reversal path forward, 
dwell time, backward movement to the last position, dwell time 
and automatic recording of the measuring point, backward 
movement to the point before last, dwell time and automatic 
recording of the measuring point, ..., datum, dwell time and 
automatic recording of the measuring point. 
Possible further cycles: Like the 1st forward cycle, this cycle 
would also begin with a backward movement by the reversal 
path.  
 

 

 

Ensure that there are no “forgotten” compensation data 
saved in the control that could cause an undesired 
movement in the wrong direction or corrupt the 
measurement. You might try running the machine 
program without the encoder. 

 
Measuring assembly 

 Ensure that the IK 220 PC counter card was installed in your 
PC according to the instructions in the User’s Manual. 
Alternatively you can use the EIB 741. Please ensure an 
available peer-to-peer network connection to the EIB 741 
(address and subnet mask of the TCP/IP connection). 
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Now mount the encoder according to the instructions in the 
manual.  
 

 

 
When connecting the measuring cables to the X1 input of 
the IK card (or X11 of the EIB 741), be sure to leave 
enough slack to compensate any machine movement 
during measurement. 

 
 Before starting ACCOM, connect the enclosed hardware 
key with ld. Nr. 590255-01 or 590255-02 to one free USB port. 
 
After calling ACCOM, proceed as follows: 
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1. Settings for the angle encoder and the counter card 
 Under Options > Settings for angle encoder you set the 
parameters for the angle encoder used. 
• Count direction: Here you can manually choose the count 
direction or activate the automatic direction initialization under  
Measure > Directions. 
• Signal periods per 360 degree: Here you enter the line 
count (signal periods/revolution) of the encoder you are using. 
(Automatically read out from an Endat angular encoder). 
Input range: 16384 to 180 000 
 

 
 
 Under Options > Counter card  you set the parameters for 
the PC counter card. 
• Type counter card: Here you select the model of counter 
card that you are using. 
• Signal input: Here you select the type of measuring signal 
(1Vpp or 11µApp). With an EIB 741 you can use Endat devices 
as well 
• Address EIB 741: Here you enter the IP address of the EIB 
741 (see also EIB 741 user manual). Alternatively you may use 
the DHCP hostname in a company network. However it is not 
recommended due to the high data acquisition rate. 
This setting is not needed for the IK 220. 
• Automatic connection at program start: ACCOM connect 
to the EIB 741 at the next program start automatically if chosen. 
A valid connection to the EIB 741 is required! 
• Test IK (IK 220): Here you can then test the counter card for 
proper function.  
• Connect/Disconnect (EIB 741 only): The EIB 741 will be 
connected or disconnected here. 
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Ensure that you have entered the proper model, address 
and signal input of the counter card. If the line count is 
entered incorrectly, the distances will be measured too 
large or too small. 

Note 
Connect the angle encoder to the X1 input on the counter card 
and respectively to X11 on the external interface box. 

 
 

 
If you have problems receiving data from the counter 
card, use the test programs on the provided driver CD to 
check whether the card can be used. 

Note 
If you would like to check the amplitude of the measuring 
signals from an encoder, you can use the menu item Equipment 
> Oscilloscope to display the incoming measuring signals as 
Lissajous figures. 
 

 

 
If the displayed signal amplitude is too low, check 
whether the settings for the interface are correct and 
whether the encoder is correctly installed. Then start 
ACCOM again. Do not engage or disengage any 
connectors until you have exited ACCOM! 
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2. Specifying the unit of measure 
 With the menu item Options > Unit of measurement you 
specify the desired unit of measure. Close the dialog box with 
OK. 
• The units can be displayed as angular seconds (”), milli-
degrees or milli-radians. 
 

 
 

Note 
1” is approximately 0.005 milli-radians or 5 µm per meter. 
 
 
 

Position display 
With the menu item Equipment > Position display you can call 
the position display for the connected encoder and, for 
example, check the positive counting direction of the angle 
encoder. If you call this function after setting the position (see 
section 6, “Set datum”), before the test you should check again 
whether your datum is set correctly and, if not, enter it again. 
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3. Measurement parameters 
 By calling the menu item Options > Measurement 
parameters or by clicking the icon, you open the following dialog 
box in which you can adjust the measurement parameters. 
 

 
 
• Measurement axis: Select here the axis of measurement. 
• Amount of pos.: The number of positions is defined 
automatically when the nominal positions are specified. 
• Nominal positions: You have a choice among three 
possibilities: 
  1st/2nd point 
  1st/last point 
  1st point/step width 
  All points 

1st/2nd point: Here you enter the first and second 
measuring points as well as the total number of measuring 
points (including the first and last). ACCOM automatically 
calculates all measuring points and shows them in the 
position list. 
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1st/last point: Here you enter the first and last measuring 
points as well as the total number of measuring points 
(including the first and last). ACCOM automatically 
calculates all measuring points and shows them in the 
position list. 
1st point/step width: Here you enter the first measuring 
points and the step width between the measurement points 
as well as the total number of measuring points (including 
the first and last). ACCOM automatically calculates all 
measuring points and shows them in the position list. 
All points: Here you can enter all positions, which are then 
shown in the position list. 

 
 

Note 
The nominal positions have to be either in monotonically 
increasing or in monotonically decreasing order. 
 
 

 
 
 

Note 
With Save you can save the file under any name and edit it 
later with the editor or a spreadsheet program such as Microsoft 
Excel or Open Office. In this way you can also generate random 
values. With Load you can read existing files into the 
measuring program. 
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• Trigger mode—Manual: In this setting you must manually 
confirm that the measuring position has been reached. 
• Trigger mode—Automatic: 
 Position window: Enter here the size of the positioning 

window (nominal position ± position range) within which a 
momentary position is considered to have been reached. 
Be sure not to enter too small a range, otherwise 
measurements will be interrupted by large error values. 

 Standstill speed: For automatic position detection, the 
change in position must be smaller than the standstill 
speed specified here. 

 
• Cycles: Here you enter how many times in a row the nominal 
positions are to be scanned. You must previously have clicked 
Backward cycles (positions are also approached backward), 
otherwise only one forward cycle is possible. 
 
• Reversal angle: The angle to be traversed so that the same 
nominal position can be approached from the opposite 
direction. ACCOM recognizes the backward movement after 
half the reversal angle. For extremely high traversing speeds, 
enter a dwell time at the end of the reversal angle in the NC 
program. 
 
• Dwell time: Here you specify how long the machine is to wait 
at one position until it approaches the next position. ACCOM 
automatically records the measured values after half the dwell 
time. 
 
• Measuring mode—Linear: All positions are traversed in 
sequence. 
• Measuring mode—Rotatory: The axis moves forward by the 
entered number of measuring cycles and then reverses its 
direction to move backward and return to the starting point. Last 
position of measurement mode "Rotatory" must be less than 
360°. 
• Measuring mode—Step cycle: Each nominal position is 
approached in positive and negative direction as many times as 
is defined under Cycles. The process is repeated in sequence 
at all positions. 
 
• Backward cycles: Here you specify whether the nominal 
position will also be approached backward. If Backward cycles 
is not checked, you can run only the linear measuring process 
with one forward cycle. 
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• Check position traverse: This option should be enabled for 
all ISO-230-2 measurements. ACCOM then always checks 
whether a measurement position has been skipped. If that 
happens the trigger conditions "position range" and "standstill 
range" should be increased. 
However this option has to be disabled for ISO 230-3 
measurements with additionally heating cycles in between the 
measurement cycles. Here the trigger conditions have to be 
increased as well. 
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4. Setting the NC interface 
 If you wish to transfer the measuring program in ACCOM to 
a HEIDENHAIN control, select  Options > NC programming  to 
open a dialog box in which you can configure the network 
connection. 
 

 
 
• Mode: Choose between HEIDENHAIN or ISO format. 
• Feed rate: Here you enter the nominal feed rate for the 
circular motion. 
Input range:  0.001 to 100 000 mm/min or 
   0.000 04 to 3900 inches/min 
• Program name: Here you give the program a name (the 
extension .H stands for HEIDENHAIN, .I stands for 
HEIDENHAIN ISO and .txt for general ISO). 
• Decimal place: Select the decimal place of the NC programs. 
• M functions: Here you enter additional M functions which are 
necessary to run the NC program on the control. 
The M functions are added to the first NC block. 
Example in HEIDENHAIN conversational programming:  
2 L X0 F1000 M31 
• TCP/IP address: Here you enter the TCP/IP address or 
DHCP hostname of the control for the data transfer via network 
connection. 

G-Code options 
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 By clicking the control button Options the following dialog 
box opens. Here you can configure some ISO format settings 
which are suitable to the control.  
 

 
 
• Position (export only): This parameter is used in the export 
of an ISO NC program only. For absolute positions G90 is 
added at the NC program start, for incremental positions G91 is 
used.  
For absolute NC programs it is useful to add a datum shift (e.g. 
G54). 
• Circle center: The input of the circle center point acc. to the 
German standard DIN 66025 is done incremental to the last 
position or absolute. Usually I, J, K are used with incremental 
positions. Valid is also an absolute position with I, J, K. 
(depends on the control). 
• Feed rate: This parameter is only valid for an INCH program. 
The feed rate can be set in Inch/Min or Inch/10Min 
(HEIDENHAIN default). 
• G-code for Inch/MM: You can choose whether to use 
G71/G70 for NC programs or not. 
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In the dialog box Parameters for NC-programming you may 
add the following data for the ISO format programming: 
• Additional lines at program start: Here you can add 2 user 
or control specific lines at program start (e.g. G54). 
• Additional lines at program end: Here you can add 2 user 
or control specific lines at program end (e.g. M30). 
 
 

Network cable 
 
 Connect the TNC by a (crossed) network cable directly to the 
PC or by using a standard network cable with a hub or a switch 
to the company network. 

Note 
Peer-to-peer (direct connection): You need to set the IP-
Address of the PC in Control Panel / Network / TCP-IP / 
Properties (depends on the operating system). As default the 
value for the IP-Address will be given automatically in a 
company network (from the DHCP Server). 
 
 
LAN (Network) with a 1:1 cable 

 
 
 
Peer-to-peer (direct connection) with a (crossed) cable! 
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5. Directional detection 
 Before the first measurement, ACCOM needs to know the 
positive counting direction of the rotary movement. In the menu 
item Measure > Directions, ACCOM prompts you to turn the 
machine axis in the direction and by the angle shown in the 
dialog box. 
This menu item is not shown if deactivated under Options > 
Settings for the angular encoder. 
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6. Set datum 
 In the menu item Measure > Set datum you assign ACCOM 
a position value in agreement with the control. 
Example: 
If the measuring axis is located at the starting position (e.g. 0°), 
you assign this position the value (0° too). 
 

 
 

 

 
When using “Set datum” and “Set direction,” do not forget 
the influence on the measurement of the backlash in NC 
axes, especially at the beginning of the measurement. 
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7. Generating and transferring an NC program 
 If you wish to generate and transfer an NC program, call the 
menu item File > Upload NC program to TNC, and select the 
form in which you would like to transfer the NC program. 
 

 
 
• Generate according to options: This button calls a dialog 
box entitled “Generate NC program for measurement” in which 
you define the parameters for the NC program. 
• Load from file (TCP/IP): In the TCP/IP operating mode, a 
finished NC program is transferred from the file system of your 
PC to the NC control by a network connection. 
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• Mode: Choose the format of the NC program. 
• Feed rate: Here you enter the nominal feed rate for the 
positioning motion. The input is in °/min. 
• Program name: In TCP/IP mode you add the extension .H for 
HEIDENHAIN format or .I for ISO format to the NC program. 
• Axis: Select here the machine axis being used. 
• Save: Click to save the NC program. 
• Cancel: Click to close the dialog box without saving changes. 
• Upload in: Click to start the upload. 
 
This generates an NC program for the VM rotary table 
measurement and transfers it to the TNC. You may choose a 
directory on the TNC directly from ACCOM in TCP/IP mode. 
 

 

 
The following prerequisites must be met for the correct 
execution of the NC program.  
1. At program start, the rotary axis must be located at the 
starting point. 
2. The correct program must be selected on the control. 

 
 

 
The TNC does not answer if the network is not 
connected. 
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8. Generating a calibration chart 
 With the menu item Measure > Calibration chart or by 
clicking the icon you can define the calibration chart for the 
measurement by entering information on the measurements in 
the calibration window. By clicking yes or no you can specify 
whether the chart window will open automatically after each 
measurement. 
 

 
 
If you enter the chart data only for measurement 1, the data will 
automatically also apply to the other measurements. The charts 
can also be saved for editing later in the course of evaluation. 
ACCOM saves this data together with the measured data, and 
outputs it with the menu items Evaluate > Raw data, Evaluate > 
Characteristic data and Graphic > Print. 

Note 
The HEIDENHAIN reference measurement system must be 
specified in the chart to do a printout.  
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9. Settings for automatic measurement 
 If you would like to automate the measuring process you can 
use the menu item Measure > Setup to specify the desired 
sequence of operations. 
 

 
 
• Open chart window automatically after a measurement: 
 Yes: The calibration chart window opens automatically 

after each measurement: 
 No: You can make the calibration chart entries later. 
• Automatic printing of graphic display after a measurement: 
 Yes: Click the Representation button to select the type of 

print. 
 Auto scaling—Yes/No: Choose whether the graphic is to 

be scaled automatically. 
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• Save after measurement: 
 Automatic: If you would like to save the measurement 

automatically, click File name and enter the desired name 
and path. 
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10. Start measurement 
 Select the menu item Measure > Start measurement or click 
the associated button to open a dialog box with which you can 
start the measurement after entering the parameters. 
 

 
 
• Measurement 1-4: Click the number under which the 
measurement is to be shown later. 
• Scaling Dmax/Dmin: Enter here the upper and lower limit of 
the expected error. You can change the scaling at any time 
later during the evaluation. 
 

 

 

The following conditions must be fulfilled for a correct 
measurement: 
1. The measurement parameters entered in ACCOM 
must correspond to reality. 
2. The measured axis and the encoder must be at the 
starting position. 
3. The correct NC program must be selected. 
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 Start: After you click this button, ACCOM waits for the 
beginning of measurement. Start the measuring program on the 
machine tool. The progress of measurement is shown on the 
screen. You can terminate the measurement with Cancel. 
 

 
 

 

 
When using the NC program generated by ACCOM, at 
the beginning of measurement the angle encoder should 
be at the reversal position. Recording begins after the 
subsequent forward motion to the starting point. 

 
If you have not automated the measuring sequence, a dialog 
box for saving data appears after the measurement. 
 
With Measure > Start measurement you can start further 
measurements. 
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Entering temperature values 
If you wish to save the ambient temperature values and other 
temperature values, the ISO 230-3 standard must be selected 
under the menu item Evaluate > Standard. Then select the 
menu item Evaluate > Temperature table to open a dialog box 
in which you can enter the temperature for each cycle. 

Note 
At least two temperature values are required. The temperature 
curve between them is interpolated linearly.  
 
Then save the file with the menu item File > Save 
measurement. 
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11. Open measurement 
 With File > Open measurement or by clicking the associated 
button you can load the measured data for further evaluation 
and display. The following screen appears. 
 

 
 
This dialog window enables you to open the measurements in 
any sequence. 
This menu item also enables you to call other motion error 
traces to the screen for further evaluation. 
 

 

 
The results of measurement are loaded into the system 
with the menu item Open measurement. This is a 
prerequisite for display. With the menu item Evaluate > 
Graphic you can influence how and whether the motion 
error traces are displayed (see also section 15, “Graphic 
Display”). 
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12. Evaluate raw data 
 You can view the raw measurement data with the menu item 
Evaluate > Raw data or by clicking the associated symbol. 
ACCOM shows every measured nominal position together with 
the associated error in degrees and the selected unit of 
measurement (see section 2, “Specifying the unit of 
measurement”). 
 

 
 

Note 
The ACCOM data is saved in an ASCII file. The raw data is 
saved line by line, separated by tabs. You can load or import 
this file for further processing in other programs like Matlab, 
Origin, Microsoft Excel or Open Office. 
 
To print the raw data, click the print symbol. 

 
Click Cancel to exit the dialog box. 
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13. Select standard for evaluation 
 In the menu item Evaluate > Standard you can select the 
guideline for further evaluation. 
ISO 230-2 
VDI/DGQ 3441 
ISO 230-3 
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14. Characteristic values 
 With the menu item Evaluate > Characteristic data, or by 
clicking the associated symbol, you can display the results 
calculated from the measured data according to ISO 230-2 or 
VDI/DGQ 3441.  
 
To print the accuracy data, click the print symbol. 

 
Click Cancel to exit the dialog box. 
 
• Example of accuracy data as per ISO 230-2: 
 

 
 
 

186 HEIDENHAIN 



 Measuring Procedure for VMR 

• Example of accuracy data as per VDI/DGQ 3441: 
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15. Graphic display of measurement results 
 You can specify the display mode of the motion error traces 
according to the selected standard with the menu item Evaluate 
> Graphic or by clicking the associated symbol.  
 

 
 
• Display: Select the measurement to be displayed. 
• Scaling deviation: 
 Fixed: Enter the upper and lower limit of the error display. 
 Automatic: The scale is determined automatically. 
• Scaling angle (abscissa): 
 Fixed: Enter the upper and lower limit of the abscissa. 
 Automatic: The limits of the abscissa are determined 

automatically. 
• Representation: The available display modes depend on the 

selected evaluation standard. 
 ISO 230-2: Separate cycles 
   ISO 230-2 
   Averaged deviation 
   Backlash 
   Repeatability  
 VDI/DGQ 3441: Separate cycles 
   Characteristic values 
 ISO 230-3: Position drift as per cycles 
   Position drift as per time 
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• Separate cycles 
 

 
 
• Characteristic values 
Graphic as per VDI/DGQ 3441 
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• ISO 230-2 Characteristic values 
Graphic as per ISO 230-2 
 

 
 
• Averaged deviation 
Graphic as per ISO 230-2 
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• Backlash 
Graphic as per ISO 230-2 
 

 
 
• Repeatability  
Graphic as per ISO 230-2 
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• Position drift (cycles) 
Graphic as per ISO 230-3 
Temperature input under Evaluate > Temperature table. 
 

 
 
• Position drift (time) 
Graphic as per ISO 230-3 
Temperature input under Evaluate > Temperature table. 
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16. Running linear compensation on an NC control 
ACCOM enables you to read the compensation positions 
defined in the TNC and output the correct compensation values 
after the measurement. 
 
Proceed as follows: 
 
 Before entering the measuring parameters, use the menu 
item File > Download TNC compensation to transfer the 
compensation position table from the TNC to ACCOM. 
Select between the standard format COM for current 
HEIDENHAIN TNC controls. 
 

 
 
The following window with the PLC directory of the 
HEIDENHAIN control appears in TCP/IP mode. Before you can 
access the PLC directory it is necessary to enter the PLC code 
number. For this purpose a dialog box appears once. In the 
PLC directory you can choose explicitly the compensation value 
table which should be written into by ACCOM. 

Note 
To build a new table see technical manual of the TNC. 
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 Enter the measuring parameters with the menu item Options 
> Measurement parameters. ACCOM automatically transfers 
the position values from the TNC compensation table. 
 

 
 
 Specify the NC interface. 
 
 Run the directional detection and set the position. 
 
 Generate the NC program and transfer it. 
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 Generate the calibration chart. 
 
 Run the measurement. The position error values are then 
used as compensation data. 
 
 After the measurement, use the menu item File > Show 
compensation values to call a list of compensation values. 
• You can display and save the compensation values averaged 
from either all measuring cycles or just from the forward or 
backward cycles. 
 

 
 
 If you click Save, you can later read the ASCII file with a text 
editor or e.g. Microsoft Excel or Open Office. 
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 Output the compensation value table through the menu item 
File > Upload TNC compensation. In the following dialog box 
you can select the compensation values. 
 

 
 
• Select compensation column:  Choose the column of the 
compensation table which you would like to correct. 
 
• Compensation values: 
 Mean value: The mean value of the position error of all 

forward and backward cycles will be used as compensation 
values. 

 Forward cycles: The position error of the forward cycles 
will be used as compensation values. 

 
• Use of the compensation values: 
 Absolute: Existing values in the chosen column will be 

overwritten. You should use this option if there was no non-
linear axis compensation active while measuring or the 
specified column was empty. 

 Incremental: This option allows adding a position error to 
existing compensation values in the specified column.  

 
• Compensation of backward cycles: 

TNC 640: The position error of the backward cycles will be 
written in column BACKLASH in the same file 
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iTNC 530:  Choosing this option will generate a second 
compensation file with the position error of the backward 
cycles in the same column. This compensation table may 
be used by newer iTNCs for the negative direction of 
traverse. 
Example: Name of the compensation table: c.com -> then 
the name of the file for the negative direction of traverse is: 
c-.com.  
 

After confirmation with Ok the next dialog box will be displayed 
where you can select the output. 
 
• Upload table by network (TCP/IP): Output by network 
connection in TCP/IP protocol. 
• Save: Output to the file system. 
 

 
 
The following window with the PLC directory of the 
HEIDENHAIN control appears in TCP/IP mode. Here you can 
choose the directory and filename of the compensation value 
table on the TNC. 
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After you have installed the compensation values, be sure 
to run an inspection measurement. 

 
 

Color settings of the graphic 
If you are not satisfied with the color setting of the graphics, 
you can change the color of the error traces, of the coordinate 
system and of the graphic background with the menu item 
Options > Color setting. 
 

Saving/loading the options 
You can save these settings with the menu item Options > Save 
options. 
You can call these settings with the menu item Options > Load 
options. 
 

Exporting the measurement graphic 
If you wish to export the measurement graphic as a file 
without a log, you can save it as a bit map using the menu item 
Graphic > Save. 
 

Printing the graphic 
You can print the graphic with the menu item Graphic > Print. 
You can change the printer settings with the menu item File > 
Printer setup. 
 

Saving a measurement 
If you make changes to a calibration chart, you can save 
them with the menu item File > Save measurement or by 
clicking the Save button. 
As an alternative, you can also save the measured data with 
the menu item File > Save all measurements. 
 

Clearing the screen 
To remove the motion error traces from the screen, you can 
clear the screen with the menu item Graphic > Close. 
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Editing the calibration charts 
If you would like to edit the calibration charts you can select 
the desired chart with the menu item Measure > Calibration 
chart or by clicking the associated symbol. 
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Measuring Procedure for DBB circular test 

Machine cleaning 
 Before beginning to mount the encoder, clean the area of the 
machine tool in which the measurements are made. Pay special 
attention to any chips and oil or grease residue that could fall 
onto the encoder. The DBB 110 has magnetic parts that can 
attract metal chips! 
 

 

 

Give the encoder time to adjust to the ambient 
temperature before you begin mounting it. This will help 
to prevent thermally induced error. 

 
Test program 

To best enable the software to calculate and assign all error, a 
circular test should include at least one complete circle in 
positive direction and one in negative direction (see ISO 230-4). 
With HEIDENHAIN controls, the machine program can be 
transferred directly from ACCOM. For non-HEIDENHAIN 
controls, a typical test program for complete circles could be as 
follows, whereby movement must be measured only in the 
measuring plane. 
 
Part 1, positive direction: The spindle is on the circle radius at 
30° (see radius of DBB 110). The center point is the tower of 
the DBB. Closed circular counterclockwise movement without 
interruption over 360°. Stop (you must save between 
measurements). 
Part 2, negative direction: Closed circular clockwise 
movement without interruption over 360°. Stop. 
 

 

 

Ensure that there are no “forgotten” compensation data 
saved in the control that could cause a movement 
perpendicular to the encoder or corrupt the measurement. 
The spindle must not rotate. If necessary, ask your 
machine tool builder how it can be fixed. You might try 
running the machine program without the encoder. The 
must be no radial movements. The maximum measuring 
range is ± 5 mm. 

 
Measuring assembly 

 Ensure that the IK 220 PC counter card was installed in your 
PC according to the instructions in the User’s Manual. 
Alternatively you can use the EIB 741. Please ensure an 
available peer-to-peer network connection to the EIB 741 
(address and subnet mask of the TCP/IP connection). 
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Now mount the DBB 110 according to the instructions in the 
manual.    
 

 

 

When connecting the measuring cable to input X1 (X11), 
be sure to leave enough slack to compensate any 
machine movement during measurement. 

 
 Before starting ACCOM, connect the enclosed hardware 
key with ld. No. 590255-01 or 590255-02 to one free USB port. 
 
After calling ACCOM, proceed as follows: 
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1. Select measuring method 
After ACCOM is started, a dialog box appears in which you can 
select the type of measurement. 
 
 Click the DBB circular test button to start the corresponding 
program part. 
 
With the menu item File > Select measuring method or by 
clicking the icon you can select the individual measuring 
methods from within the running program. 
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2. Specifying the unit of measure 
 With the menu item  Options > Unit of measurement  you 
specify the desired unit of measure. Close the dialog box with 
OK. 
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3. Settings of the encoder and the counter card 
 Under  Options > Measuring interface  you set the 
parameters for the encoder used. 
• Signal period: Here you set the signal period (as its distance 
in µm) of the encoder you are using. The default setting for the 
signal period is 10 µm. 
Input range:  0.1 to 20 µm 
• Location of reference: Here you enter the position of the 
reference point printed on the DBB 110. The measured values 
are expressed with respect to this position after Measure > 
Traverse over reference point.   
Input range:  10 to 500 mm 
 

 
 
 Under  Options > Counter card  you set the parameters for 
the counter card. 
• Type counter card: Here you select the model of counter 
card that you are using. 
• Signal input: Here you select the type of measuring signal. 
• Address EIB 741: Here you enter the IP address of the EIB 
741 (see also EIB 741 user manual). Alternatively you may use 
the DHCP hostname in a company network. However it is not 
recommended due to the high data acquisition rate. 
This setting is not needed for the IK 220. 
• Automatic connection at program start: ACCOM connect 
to the EIB 741 at the next program start automatically if chosen. 
A valid connection to the EIB 741 is required! 
• Test IK (IK 220): Here you can then test the counter card for 
proper function.  
• Connect/Disconnect (EIB 741 only): The EIB 741 will be 
connected or disconnected here. 
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Ensure that you have entered the proper model, address 
and signal input of the counter card. If the signal period is 
entered incorrectly, the circles will be measured too large 
or too small. 

 
 

 

If you have problems receiving data from the counter 
card, use the test programs on the provided driver CD to 
check whether the card can be used. 

Note 
If you would like to connect an encoder other than the DBB 
110, you can use the menu item  Equipment > Oscilloscope  to 
display the incoming measuring signals as Lissajous figures 
and use them if necessary to make the fine adjustment of 
measuring signals. 
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4. Parameters of the measurement 
 By calling the menu item  Options > Parameters of the 
measurement  or by clicking the icon, you open the following 
dialog box in which you can adjust the parameters of the 
measurement. 
 

 
 
• Start of measurement—manual: A countdown of 5 seconds 
begins. In the last three seconds a peep tone is output. After 
the third peep tone the measurement starts. 
• Start of measurement—automatic: The measurement starts 
as soon as the radius has changed by the value shown in the 
starting window. 
• Measuring plane: Click the working plane of the machine 
tool. 
• Amount of points: Number of measuring points per 
measurement. 
Input range: 36 to 8000 measuring points 
• Starting window: Enter here the size of the starting window 
for the automatic start detection. 
Input range:  1 to 100 µm 
   0.000 04 to 0.004 inches 
• Starting angle: Here you enter for the working plane the 
angle from which ACCOM is to begin the measurement. 
Input range in XY plane: 0 to 360° 
Input range in YZ plane: 0 to 180° 
Input range in ZX plane: 0 to 90° or 270 to 360° 

Note 
Since the orthogonality of the axes is measured at 45°, and the 
axis reversal movements occur at the quadrant transitions (0°, 
90°, 180°, 270°), a starting angle of 30° is recommended for 
the XY plane. 
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• Measuring angle: Here you enter the angle over which the 
measurement is to be made in the adjusted measuring plane 
and starting angle (YZ and ZX plane). 
Input range in XY plane: 1 to 720° 
Input range in YZ plane: Depending on the start angle 1 to 180° 
Input range in ZX plane: Depending on the start angle 1 to 180° 
 

 

 
The measuring angle and starting angle together must 
not exceed the maximum traverse range of the machine 
tool or the input range of ACCOM. 

 
• Radius: Here you enter the nominal radius of the circle.  
Input range:  100 to 500 mm 
   4 to 19.6 inches 
 
Then conclude the input with OK. 

Note 
With the menu item  Equipment > Position display you can call 
the position display for the connected encoder. 
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5. Setting the NC interface 
 If you wish to transfer the measuring program in ACCOM to 
a HEIDENHAIN control, select  Options > NC programming  to 
open a dialog box in which you can configure the network 
connection. 
 

 
 
• Mode: Choose between HEIDENHAIN or ISO format. 
• Feed rate: Here you enter the nominal feed rate for the 
circular motion. 
Input range:  0.001 to 100 000 mm/min or 
   0.000 04 to 3900 inches/min 
• Program name: Here you give the program a name (the 
extension .H stands for HEIDENHAIN, .I stands for 
HEIDENHAIN ISO and .txt for general ISO). 
• Decimal place: Select the decimal place of the NC programs. 
• M functions: Here you enter additional M functions which are 
necessary to run the NC program on the control. 
The M functions are added to the first NC block. 
Example in HEIDENHAIN conversational programming:  
2 L X0 F1000 M31 
• TCP/IP address: Here you enter the TCP/IP address or 
DHCP hostname of the control for the data transfer via network 
connection. 
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G-Code options 
 
 By clicking the control button Options the following dialog 
box opens. Here you can configure some ISO format settings 
which are suitable to the control.  
 

 
 
• Position (export only): This parameter is used in the export 
of an ISO NC program only. For absolute positions G90 is 
added at the NC program start, for incremental positions G91 is 
used.  
For absolute NC programs it is useful to add a datum shift (e.g. 
G54). 
• Circle center: The input of the circle center point acc. to the 
German standard DIN 66025 is done incremental to the last 
position or absolute. Usually I, J, K are used with incremental 
positions. Valid is also an absolute position with I, J, K. 
(depends on the control). 
• Feed rate: This parameter is only valid for an INCH program. 
The feed rate can be set in Inch/Min or Inch/10Min 
(HEIDENHAIN default). 
• G-code for Inch/MM: You can choose whether to use 
G71/G70 for NC programs or not. 
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In the dialog box Parameters for NC-programming you may 
add the following data for the ISO format programming: 
• Additional lines at program start: Here you can add 2 user 
or control specific lines at program start (e.g. G54). 
• Additional lines at program end: Here you can add 2 user 
or control specific lines at program end (e.g. M30). 
 
 

Network cable 
 
Connect the TNC by a (crossed) network cable directly to the 
PC or by using a standard network cable with a hub or a switch 
to the company network. 

Note 
Peer-to-peer (direct connection): You need to set the IP-
Address of the PC in Control Panel / Network / TCP-IP / 
Properties (depends on the operating system). As default the 
value for the IP-Address will be given automatically in a 
company network (from the DHCP Server). 
 
 
LAN (Network) with a 1:1 cable 

 
 
 
Peer-to-peer (direct connection) with a (crossed) cable! 
 

 
  

210 HEIDENHAIN 



 Measuring Procedure for DBB 

6. Generating and transferring an NC program 
 If you wish to generate and transfer an NC program, call the 
menu item File > Upload NC program to TNC, and select the 
form in which you would like to transfer the NC program. 
 

 
 
• Generate according to options: This button calls a dialog 
box entitled Generate NC program for measurement in which 
you define the parameters for the NC program. 
• Load from file (TCP/IP): In the TCP/IP operating mode, a 
finished NC program is transferred from the file system of your 
PC to the NC control by a network connection. 
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• Mode: Choose the format of the NC program. 
• Feed rate: Enter here the nominal feed rate of motion. 
Input range:  0.001 to 100 000 mm/min 
   0.000 39 to 3937 inches/min 
• Program name: In TCP/IP mode you add the extension .H for 
HEIDENHAIN format or .I for ISO format to the NC program. 
• Measuring plane: Click the working plane of the machine tool. 
• 1st Direction of rotation: Select the direction in which the 
first of the two circular movements defined by the control is to 
be made. 
• Starting angle: Enter here the same starting angle as you did 
before under menu item Parameters of measurement. 
• Measurement angle: Enter here the same measurement 
angle as you did before under menu item Parameters of 
measurement. 
 

 

 
The measuring angle and starting angle together must 
not exceed the maximum traverse range of the machine 
tool or the input range of ACCOM. 

 
• Save: Click to save the NC program. 
• Cancel: Click to close the dialog box. 
• Upload: Click to start the upload. 
 
Now an NC program is generated for both directions of rotation 
and transferred to the root directory of the TNC. 
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A program is generated that consists exclusively of 
circular arcs with constant radius. The following two 
prerequisites must be met: 
1. The mounting point of the DBB 110 on the milling 
machine table must match the datum of the NC machine. 
Set the datum if necessary. 
2. The spindle head must be at the 0° position of the test 
circle. 

 
These two conditions are met if the DBB 110 has been installed 
according to the instructions of the operating manual. 
The program first moves the spindle head into the starting angle 
position and stops there. Here you can start the 
measurement through ACCOM.  Then start the NC machine, 
which moves on by the measurement angle and then stops. 
When it starts again the spindle head moves from the end 
angle back to the starting angle. 
 

 

 
The TNC does not answer if the network is not 
connected. 
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7. Generating a calibration chart 
 Through the menu item Measure > Calibration chart or by 
clicking the icon you can define the calibration chart for the 
measurement by entering information on the measurements in 
the calibration window. By clicking yes or no you can specify 
whether the chart window will open automatically after each 
measurement. 
 

 
 
If you enter the chart data only for measurement 1, they will 
automatically apply also to the other measurements. The charts 
can also be saved or edited later in the course of evaluation. 
ACCOM saves these data together with the measured data and 
prints them through the menu items Evaluate > Measured data, 
Evaluate > Characteristic data and Graphic > Print. 
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8. Calibrating the measuring assembly 
 

Traversing the reference mark 
 The measuring assembly must be calibrated before the first 
measurement. To do so, call the menu item  Measure > 
Traverse over reference point.  Follow the instructions in the 
dialog box. If the message  The DBB has been referenced  
appears, rehook the DBB. 
Now you can go directly to the menu item  Measure > Start 
measurement.  
 

 
 

 

 
When you rehook the DBB 110, ensure that the 
measuring cable has enough slack for the rotary 
movements. 

 

ACCOM 215 



Measuring Procedure for DBB 

Datum setting 
 If you are using a DBB without reference mark or without 
calibrated extension, you must enter the current deflection 
under the menu item  Measure > Set datum. 
 

 
 
If you omit this point, the point that you have entered under 
menu item  Options > Measuring interface > Location of 
reference  appears automatically. 
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9. Start measurement 
 To start measuring, select the menu item  Measure > Start 
measurement  or click the symbol. Then the dialog box appears 
in which you can start measuring after entering the following 
parameters. 
 

 
 
• Measurement 1-4: Click the number under which the 
measurement is to be shown later. 
• Direction of rotation: Select here the direction of rotation for 
the circular movement. 
• Feed rate: Enter here the nominal feed rate of motion. 
Input range:  0.001 to 100.000 mm/min 
   0.000 04 to 3900 inches/min 
• Graphics: Enter here the resolution for displaying the circular 
form. You can change the resolution at any time during the 
evaluation. 
Input range:  0.1 to 10.000 µm/div. 

0.000 04 to 0.4 inches/div. 
Note 

A complete circular test should include at least two complete 
circles of the same radius, center, and feed rate, but with 
different direction of rotation. 
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 Start: After you click this button, ACCOM waits for the 
beginning of measurement. Start the circular movement on the 
machine tool. In the status line, ACCOM shows the condition of 
measurement. You can terminate the measurement with 
Cancel. 
 

 
 

 Note 
If ACCOM does not begin measuring although the circular 
movement was made on the machine tool, wait for a period of 
15 to 30 seconds after the movement ends. If the menu item  
Evaluate > Graphic > Representation  was set to Center or 
Radius compensation (see point 14, Graphic Display of Circular 
Test Results), there is no online display. 
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Data storage 
After conclusion of measurement, the following dialog box 
appears for data storage. 
 

 
 
With Measure > Start measurement you can start further 
measurements. 
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10. Open measurement 
 Through File > Open measurement  or by clicking the 
associated button you can load the measured data for further 
evaluation and display. The following screen appears. 
 

 
 
Since up to four measurements can be shown simultaneously, 
this dialog box enables you to open the measurements in any 
sequence. 
This menu item also enables you to call other motion error 
traces to the screen for further evaluation.   
 

 

 
The results of measurement are loaded into the system 
with menu item Open measurement. This is a prerequisite 
for display. Through the menu item Evaluate > Graphic 
you can influence how and whether the motion error 
traces are displayed (see also section 14, “Graphic 
Display”). 
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11. Evaluate measured data 
 You can view the raw measurement data through the menu 
item Evaluate > Raw data or by clicking the associated symbol. 
ACCOM shows every measured deviation including the 
associated angle. 
 

 
 

Note 
The ACCOM data is saved in an ASCII file. The raw data are 
saved line by line, separated by tabs. You can load or import 
this file for further processing in other programs like Matlab, 
Origin, Microsoft Excel or Open Office. 
 
To print the raw data, click the print symbol. 

 
If you click Cancel, the dialog box closes. 
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12. Select standard for evaluation 
 In the menu item  Evaluate > Standard  you can select the 
guideline for evaluating the circular test. At present only the ISO 
230-4 standard is available. 
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13. Characteristic data of the circular test 
 With the menu item  Evaluate > Characteristic data,  or by 
clicking the associated symbol, you can call the accuracy data 
calculated from the measured data according to ISO 230-4. In 
addition, ACCOM calculates the mean radius, the backlash, the 
reversal peaks, center deviation and the orthogonality 
(squareness) of the axes. 
 

 
 

 

 
Two circles are required—once each in positive and 
negative direction—for complete calculation of all 
accuracy data, particularly the circular backlash H. 
ACCOM issues a warning if you have forgotten to load 
the second file. 

 
To print the accuracy data, click the print symbol. 
 
If you click Cancel, the dialog box closes. 
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14. Graphic display of circular test results 
 You can specify the display mode of the motion error traces 
through the menu item  Evaluate > Graphic  or by clicking the 
associated symbol.  
 

  
 
• Release: Here you can select up to four previously opened 
measurements to be displayed. 
 
You can choose in principle between circular and linear 
diagrams and configure the respective settings. Scaling can 
then either be set to a fixed value or can be selected 
automatically by the system. 
 
• Scaling of the circular graphic: In the circular graphic you 
can set the desired resolution. 
Input range of resolution: 0.1 to 10 000 µm 
    0.000 004 to 0.4 inch 
• Scaling of the linear graphic: In linear graphics you can set 
the upper and lower limit or the displayed angular range for the 
deviations from an ideal circular path. 
Error from/to:  –10 000 to +10 000 µm 
    –0.4 to 0.4 inch 
Angle from/to:  0 to 360° 
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• Representation:  
Center: With this function you can display a centered view 
of the measurement  ACCOM shows you the calculated 
actual circle center. 
Radius compensation: Here the radius error is 
compensated by ACCOM in the graphic and displayed in 
the box. 

 
 

 
Before measuring you should switch off the centering 
and radius compensation function, since otherwise the 
graphic will not be shown online. 

 
You have the choice between the following display modes:
   Circle large 
   Circle small 
   Linear large 
 
• Circle large: Here, ACCOM draws up to four motion error 
traces in one circular graphic. You can switch the error traces 
on and off with the menu item  Evaluate > Graphic > Release 
measurement 1-4. 
The nominal radius is shown as a dotted line in the 
measurement graphic. 
The largest and smallest radius errors are shown as a 
dashed line in the graphic. 
 

 
 
You can load new measurements with File > Open 
measurement or by clicking on the associated button. 
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• Circle small: Here, ACCOM draws each motion error traces 
in a separate circular graphic. You can switch the error traces 
on and off with the menu item  Evaluate > Graphic > Release 
measurement 1-4. 
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• Linear large: Here, ACCOM draws up to four motion error 
traces in one linear graphic. You can switch the error traces on 
and off with the menu item  Evaluate > Graphic > Release 
measurement 1-4. In the example the scaling is fixed and the 
angle of 0 to 360° is selected. 
 

 
 
As an alternative you can also display an angular range. In the 
example the scaling is fixed and the angle of 70 to 110° is 
selected. 
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Additional circular test options 
 
 By clicking on the control button Options the following dialog 
box opens. Here you can set additional display options. 
 

 
 
• Display options for circle large/small: In the circular test 
graphic you can disable the auxiliary lines for the minimum and 
maximum radius deviation and/or the scaling values. 
• Special options for circle large/small: In the default graphic 
for the circular test the first measurement axis is shown right 
and the second axis is shown top. Alternatively the axis can be 
displayed mirrored (1st axis top, 2nd axis right). The third 
display option is: 1st axis is shown top and 2nd axis is shown 
left (axes are turned by 90 degrees).  
• Special option linear large: Alternatively you may use a 
path-time diagram for the radius deviation (time instead of 
angle). 
• Save circular test options: Here the special options for the 
circular test representation can be saved (at program end or 
change of measurement type). 
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Open measurement 
You can load new measurements with File > Open 
measurement or by clicking on the associated button. 

 
Color settings of the graphic 

If you would like to change the color setting of the graphics, 
you can change the color of the error traces, of the coordinate 
system and the graphic background with the menu item  
Options > Color setting. 
 

Saving/loading the options 
You can save these settings with the menu item  Options > 
Save options. 
You can call these settings with the menu item  Options > Load 
options. 
 

Exporting the measurement graphic 
If you wish to export the measured graphic as a file without a 
log, you can save it as a bitmap using the menu item Graphic > 
Save. 
 

Printing the graphic 
You can print the graphic with the menu item Graphic > Print. 
You can change the printer settings through the menu item 
File > Printer setup. 
 

Saving a measurement 
If you make changes to a calibration chart, you can save 
them through the menu item  File > Save measurement  or by 
clicking the save button. 
As an alternative, you can also save the measured data through 
the menu item  File > Save all measurements. 
 

Clearing the screen 
To remove the motion error traces from the screen, you can 
clear the screen with the menu item  Graphic > Close. 
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Editing the calibration charts 
If you would like to edit the calibration charts you can select 
the desired chart through the menu item Measure > Calibration 
chart or by clicking the associated symbol. 
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Typical Motion Error Traces of the Circular Test 

The motion error traces shown below are the typical results of 
measurements performed with the DBB 110 or KGM. 
The chapter contains examples of the typical error traces for 
most of the common error sources. Each trace is described 
together with the possible causes of the error. This will help you 
to diagnose the errors on your machine, but it is not a complete 
discussion of this topic. For a detailed work on the diagnostic 
procedures please refer to the “Circular Test” by Knapp and 
“Accuracy Inspection of NC Machine Tools by Double Ball Bar 
Method,“ Kakino. 
 
The DBB 110 and the KGM are complete calibration systems. 
The results of the DBB system should be used to identify error 
sources and to suggest which type of measurements or actions 
are required to improve the accuracy of the machine. The 
DBB 110 and KGM help you to find the best error compensation 
method. The values for the machine compensation can be 
calculated and adjusted until the desired results are achieved. 
 

Typical error types 
 
Roundness error: 
• Reversal peaks 
• Backlash and backlash compensation 
• Center offset 
• Cyclic Error 
• Deviation caused by ball bar cable (only with DBB 110) 
• Directional vibrations 
• Incorrect feed rate 
• Rolling of the spindle head 
• Screw-pitch error 
• Radial error 
• Random vibration 
• Encoder error 
• Mismatching of position loop gain 
• Squareness error 
• Stick slip 
• Straightness error 
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The circularity error gives some basic information on the overall 
condition of the machine tool. However, the error sources and 
the significance of individual errors are not revealed because 
the circular plot graph represents the total effect of all errors.  
 
Circularity is most often calculated with one of the following 
methods: 
 
LS Least squares circle 
MZ Minimum zone circles 
MC Minimum circumscribed circle 
MI Maximum inscribed circle 
 
Circularity is the difference of the maximum and minimum 
points of the trace pattern. 
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LSC circularity 
 

 
 

MZC circularity 
 

 
 
MZC always leads to a value smaller than or equal to LSC. 
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Reversal peaks 
 
As the name of the error describes, reversal peaks occur shortly 
after the direction of the motion of an axis is reversed. At this 
point, the axis stops momentarily and then moves rapidly to 
catch up with the movement in the reverse direction. The 
magnitude of the spike is dependent on the servo rigidity, the 
feed rate and the radius of the circle. 
 

 
Possible causes 

These peaks are caused by a type of hysteresis at the reversal 
points. Possible causes of error: 
• Large lag error caused by low loop gain 
• Backlash in the drive and feedback system, especially with 

rotary encoders. 
 
This type of error is very common on large machines and 
machines using rotary encoders as position feedback devices. 

Suggestions 
Increasing the position loop gain might decrease the size of the 
peaks. Care should be taken to find a suitable value for the 
position loop gain so that the drive system does not oscillate. 
 
Some advanced controls offer the possibility of compensating 
the reversal peaks. 
 
When measuring reversal peaks, use the largest possible 
number of measuring points. 
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Backlash and backlash compensation 
 
Backlash error appears on plots in two different ways: as 
positive and negative backlash. When moving to the defined 
test direction, positive backlash can be seen on the plot as a 
step outwards starting on the axis. Negative backlash appears 
as a step inwards starting on the axis. 

Backlash Step — Positive 
Normally, a positive backlash is caused by a deformation or 
play in the machine structure. 

Backlash Step — Negative 
Negative backlash is often caused by backlash 
overcompensation at the controller: the compensation value 
exceeds the value of the actual backlash error. 
Normally, the step occurs at approximately the same magnitude 
at both reversal points of the axis. However, due to 
deformations in the machine tool structure the values may also 
be different in actual cases. 

Possible causes 
The backlash is normally caused by some deformation or play 
in the machine structure and not by the encoder. 
 
This type of error can be detected on machines using linear 
encoders. It is normally significantly larger than the inherent 
backlash of the linear encoder, which is typically under 1 micron. 

Suggestions 
If backlash compensation is not available in the controller, 
check the machine for possible sources of backlash: 
• Drive belts or couplings between spindle and rotary encoders 
• Movement of the table 
• Play in the machine guideways 
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Backlash — Positive 
 

 
Backlash — Negative 
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Center offset 
 
Extreme error symmetrical through the center point. 

Possible causes 
This is a typical trace eccentricity error due to center offset, 
commonly seen in DBB circular tests. 
 
When setting up the Double Ball Bar it is very difficult to mount 
the tower at the exact center of rotation with the human eye. It 
is therefore very important to determine the numerical values for 
the center offset. These values are called Center Offsets and it 
is advisable that their values remain below 100 µm for both 
axes. Otherwise, the reliability of the measurement could be 
affected. 
 
Such a trace also appears if a correctly centered trace is 
compensated with offset values that do not apply to this 
measurement. 

Center offset 
 

 
 
The example plot contains a 15 micron offset in both axes. 
The scale of the plot is 10 microns. 
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Cyclic error 
 
Cyclic error appears as a cyclically changing sinusoidal motion 
error on the circular plot. The phase of the ballscrew will vary 
depending on where the test is performed on the machine. 
 

 
Possible causes 

Because the possible causes of cyclic error are manifold 
(ballscrews, encoders, resolvers, transmission, etc.), it is of 
extreme importance to know the structure of the machine tool 
and its driving mechanism in order to reach a correct diagnosis. 
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Deviation caused by the DBB cable 
 
Radial error as one angular position. 
 

 
Possible causes 

The cable may have become caught up on the machine and 
exerted a force on the ball bar that causes a radial deviation to 
be registered. 

Suggestions 
Always carry out two measurements: one in the positive 
direction followed by one in the negative direction. This allows 
the cable to wind and unwind during each measurement. If 
several measurements are carried out in one direction the cable 
will wind up until it causes a measuring error and may damage 
the ball bar. 
 
Make sure that the cable cannot catch on any part of the 
machine, bolts, clamps etc. during the measurement. On a 
vertical machine hang the cable above the spindle and allow it 
to hang down to the ball bar without touching the table. 
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Directional vibrations 
 
If vibration is caused by a particular reason, the location and 
influencing direction of the error source most probably will 
cause a directional bias in the vibration pattern. 
 

 
Possible causes 

If the direction of vibrations is parallel with one or both axes, 
it is likely that vibrations are caused by the machine itself. In 
other cases, the cause might be peripheral devices, the 
machine foundation or damping systems, etc. 
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Incorrect feed rate 
 
The reversal peaks are not located on the quadrant transitions. 
The picture below illustrates the appearance of reversal peaks 
when the feed rate is incorrect. 
 

 
Possible causes 

If the reversal peaks are spaced more than 90 degrees apart, 
the machine feed rate is lower than the value entered in the 
DBB software. 
 
If the spacing is less than 90 degrees, it is higher. 

Suggestions 
Use the feed-rate override control to set the speed correctly. 
The 100% setting of this control does not always correspond 
exactly to 100% of the feed rate. 
 
 Check the programmed feed rate and adjust it if necessary. 
 
 Check the maximum feed rate allowed by the control for 

circular interpolation. 
 
 Check the maximum circular acceleration values. 
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Rolling of the spindle head 
 
Angular movement about the Y axis results from play in the Z 
axis in the machine’s guideway. Therefore, depending on the 
test direction and on the algebraic sign of the error, the resulting 
path will be either inside or outside the nominal circle when 
observed from the other axis’ point of view. Usually the traces 
are nearly symmetrical about both axes. However, there are 
also cases in which the wear is unequal at the ends of an axis. 
In these cases, the trace will be symmetrical only about the axis 
that has the error. 
 

 
Possible cause 

The type of error presented in the picture is most frequently 
caused by play in the Z-axis guideway. 
 

242 HEIDENHAIN 



 Typical Motion Error Traces of the Circular Test 

Screw-pitch error 
 
Screw-pitch error is symmetrical about one axis. 
 

 
Possible causes 

Some control systems offer the possibility of compensating non-
linear positioning errors in one axis. 
 
The position in one axis is not continuously compensated 
according to the measured position of this axis (X=F(X)). 
 
If these compensation values are incorrect they may lead to 
the type of trace shown above. 
 
Guideway error coming from ball bearing or some other 
repeating part of the machine construction. 
 

Suggestions 
 Check the non-linear compensation parameters in the  

 control. 
 
 Use a comparator measuring system such as the VM 182 

and ACCOM-VML evaluation software to measure the 
positioning accuracy of the axes in question 
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Radial error 
 
A constant radial deviation over the whole trace. A trace whose 
mean value lies inside or outside the nominal path. 
 

 
Possible causes 

• The user did not correctly calibrate the DBB/KGM before the 
measurement. 

• The radius of the programmed contour is not the same as the 
nominal radius in the ACCOM software. 

• The DBB/KGM has been set to zero at a point other than on 
the reference mark (non-calibrated mode) and/or a circle of a 
different radius has been programmed. 

• The DBB/KGM has not been mounted horizontally to within 
the specified tolerances. 

• A large temperature difference between the DBB/KGM and 
the machine has distorted the measurement. 

• Both servos have an identical response error and both axes 
will either overshoot or lag to the same extent. 

• Identical scale errors on both axes. 
 

Suggestions 
 Check that the radius in the NC program equals the radius 

 value entered in the ACCOM software. 
 
 Allow the machine and DBB/KGM to attain the same 

temperature. 
 
 Repeat the test using different feed rates. 
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Random vibration 
 
The plot shown below presents the effect of random vibration, 
often also called as noise. 
 

 
Possible causes 

The vibration may be generated by the machine itself, for 
instance by insufficient lubrication or clearances in the slide-
guideway systems. The vibration can also be induced by the 
surrounding environment, such as other machine tools, 
compressors, ventilation fans, material handling devices or 
vehicles used for transportation. 
 
If analyzed deeper, in the case of one single cause, it can be 
noticed that the amplitude of random vibration varies around the 
circle, but frequency does not. If several causes of vibration 
exist, the result is very probably the sum of differing frequencies 
and amplitudes. 
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Encoder error 
 
Encoder error indicates the error in the linear movements of the 
axes. If no encoder error is present, the displayed path will be a 
perfect circle. However, if either one or both axes exhibit 
encoder error, the path will have an oval shape. The major axis 
of the ellipse will be parallel with one of the axes of movement. 
The ellipse does not change significantly with different feed 
rates or when the direction of rotation is changed from positive 
to negative. 
 

 
Possible causes 

Linear encoders are manufactured with high precision. 
However, when fixed on a machine tool, an error like that 
shown in the figure above may occur from mounting the 
encoder nonparallel to the axis. 
The ballscrew itself is also manufactured with high precision. 
However, when feed motions are repeated with high speed, the 
ballscrew expands due to the heat generated in the nut and the 
bearing. In a semi-closed loop type of NC, for example with 
indirect encoders, this expansion will instantly cause a 
positioning error. To avoid this, the ballscrew is normally 
manufactured with a slightly smaller pitch and is installed with 
pre-tension in order to absorb thermal expansion. 
 
Other possible causes are: 
• Faulty ballscrews and guideways that are not straight 
• Erroneous pitch error compensation or false compensation 

parameters, when positioning measurements are realized 
with a ballscrew and rotary encoder 

• In the case of linear encoders, poor scale alignment can also 
lead to an encoder error. 

• Tilt of the machine table. 
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Suggestions 
 Work in calibrated mode with an absolute radius so that you 
 know which of the axes is too small or too long. 
 
 Check the linear/non-linear compensation values in the 

 control. 
 
 Repeat the measurement at a different height in the plane 

 of measurement. If the magnitude of the error varies with 
 the height of the measuring plane, the error source is likely 
 to be a tilt of the machine table. 

 

Further information 
 
In positioning measurements of linear axes, the quantities 
measured are the linearity and local error of the linear encoder. 
The momentary position of a point on a moving slide is however 
an inseparable combination of the three dominating 
independent degrees of freedom.  
 
Other factors that influence contouring accuracy are the 
weights, the acceleration rates and correspondingly the 
deceleration rates of the moving masses. To promote the 
practical aspects, the most frequently used workpiece and/or 
fixture should be fastened on the table during measurements. 
This would produce the most realistic measuring conditions. 
 
To obtain more information, the tests should be repeated at 
different locations on the worktable. 
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Mismatching of position loop gain 
 
The magnitude of this error will tell how well the machine’s 
position control loop will respond to commands. If the length of 
the DBB bar has been calibrated, an absolute difference 
between the nominal and actual values can be obtained. If this 
is not the case, the unbalance will be seen as a relative value. 

Possible causes 
If the control of both axes is ideal, the test results in a perfect 
circle. If the control of either axis has a deviation from nominal 
(either overshoot or lag), an oval trace pattern appears with its 
major axis tilted ±45° from the machine axes. The ellipse 
rotates by 90° depending on the direction of the test. The 
magnitude of the error increases with an increasing feed rate. 
 

 
Suggestions 

 Adjust the position loop gain of the axes either at the servo 
 amplifiers or in the control using the machine parameters 
 for the position loop gain. 

 
If the servo amplifiers cannot be sufficiently adjusted and high 
product accuracy is required, you should use low feed rates 
when interpolating circles and arcs.  
 
Squareness error and servo response error have basically 
same kind of trace patterns. They can be distinguished only by 
comparing measurements from clockwise and counterclockwise 
traverse.  
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Squareness error 
 
Squareness error appears as an ellipse with a main axis tilted 
approx. +45° (negative squareness error) or –45° (positive 
squareness error) compared to the 0° axis. The ellipse does not 
change when the direction of rotation is changed from positive 
to negative. The magnitude of the error is unaffected by the 
feed rate. 
 

 
Possible causes 

An ellipse with its major axis in the second and fourth quadrants 
(90° to 180° and 270° to 360°) means that the angle between 
the axes is larger than 90°. An ellipse with its major axis in the 
first and third quadrant (0° to 90° and 180° to 270°) means that 
the angle between the axes is less than 90°. 
Repeating the test at several locations will tell whether the axes 
are bent locally or the axis is misaligned along its whole length. 
 
The measurement and evaluation of straightness and 
squareness error of the slide movements are problematic, 
because their effects combine. 
 

Suggestions 
 Repeat the measurements in both directions with feed 

 rates 500, 1000, 2000 mm/min. The shape of the traces 
 should not change by any large amount and the ellipses 
 should be rotated in the same direction independent of the 
 direction of rotation. 

 
 When necessary check the machine's squareness error,  

 for example by using a measuring probe and a granite 
 block calibrated for squareness. 
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Squareness error and servo response error have basically 
same kind of trace patterns. They can be distinguished only by 
comparing measurements from clockwise and counterclockwise 
traverse.  
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Stick slip 
 
Stick slip appears as oscillations on the plot near the reversal 
points of an axis. The sample figure below shows an example of 
stick slip motion as the negative and positive reversal points of 
the Y axis are approached. 
 

 
 
As the reversal point is approached, the feed rate in the Y 
guideway decreases, finally approaches zero and again starts 
to slowly increase in the other direction. At these low feed rates 
the static friction of the guideway has a significant influence. A 
form of stick slip effect takes place and the axis oscillates until 
the feed rate is high enough to overcome the static friction. 
 

Possible causes 
The cause of the error may be insufficient lubrication, allowing 
metal to metal contact in guideways. At higher feed rates the 
axis “floats” on an oil film on the guideway and the stick-slip 
motion disappears. 
 

Suggestions 
 If a stick-slip pattern occurs, repeat the measurements at 

 low and high feed rates. The oscillations should increase at 
 low feed rates and decrease at high feed rates. 

 
 Inspect the guideway for wear. Check the axis adjustments 

 and lubrication system, too. 
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Straightness error 
 

 
Possible causes 

• Lubrication system. Pulses from the hydrodynamic lubrication 
system usually cause effects resembling random straightness 
error. 

• Wear of the slides or guideways. For example, failures in the 
lubrication system can cause excessive wearing of the sliding 
parts and thus produce straightness errors in the movement 
of the axis.  

• Mass of the moving bodies. If the stiffness of the construction 
is not sufficient to handle the mass of the moving bodies 
(especially the table and the column), significant straightness 
errors can result. 

 
Other reasons could be collisions caused by erroneous NC 
programs or by other errors in the manufacturing process, 
improper machine tool basement or carelessness when moving 
the machine tool to a new location. To get a better picture of the 
nature and exact location of the error, measurements should be 
made at several positions in the tested plane. 
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